FreePBX: IOS iPhone Zulu softphone client won't connect

I’m running FreePBX / Asterisk 13.29.2 and have been working all day to configure Zulu UC. The FreePBX Dashboard says the zulu daemon is running. I have installed a Let’s Encrypt Certificate as the default certificate and have downloaded Zulu softphone clients for each of CentOS 7 (i.e., the FreePBX server), Windows 10, macOS 10.13.6, and on my iPhone 8 running IOS 13.3.1. Using UCP [i.e., User Control Panel] credentials for user [email protected] and wth the UCP password for user 1001, I am able to successfully bring up the Zulu softphone on the CentOS, Windows 10 and macOS clients. However, using those same credentials, I am NOT able to bring up the Zulu softphone client on my iPhone. 8002/TCP has been port forwarded to the FreePBX server in in pfSense firewall and I have tried temporarily disabling the FreePBX firewall, without success.

One additional point is that in the UCP for user 1001, when I click on “Generate QR Code”, a popup comes up stating “QR code generation only supported over HTTPS with valid certificate and hostname.”

Anyone have suggestions or comments about how I can get the Zulu softphone working on my iPhone?

The Zulu mobile client requires a proper TLS cert, which is generated with a FQDN. You must login using the FQDN of the PBX, not the IP.

@lgaetz Thanks for your reply. Yes, I’ve tried using my FQDN ( for example), identical to the FQDN that the Let’s Encrypt certificate uses, in the Server field. I also use the UCP extension, for example 1001, in both the Account Name and Username fields and UCP password for that extension. That combination DOES NOT work on my iPhone client, but if I enter the private IP of FreePBX, for example, the combination does work for the Linux, Windows 10, and macOS clients. For the test with the iPhone, the FreePBX firewall was disabled, and I tailed the zulu_err.log and zulu_out.log in /var/log/asterisk but nothing appeared.

The error that appears on my iPhone display is “Cannot connect to the server. Registration data is not valid”

Also, as mentioned above, when I “Generate QR Code”, a popup comes up stating “QR code generation only supported over HTTPS with valid certificate and hostname.” which doesn’t seem good.

So I’m presuming there’s a port on my pfSense firewall that needs to be forwarded, in addition to 8002, or perhaps settings in FreePBX that need changing.

Zulu is working now.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.