FreePBX installer stuck on partitioning

I’m unable to get the installer to complete on a MINIS FORUM mini computer. It’s booting off a USB, and the internal 61.9GB drive came with Windows installed. It’s identified as /dev/mmcblk1 and I want to replace whatever partitions are on that drive with FreePBX. I get to the autopartitioning options, (1) replace existing Linux systems [nope, there aren’t any Linux systems on there…yet] or (2) Use All Space [I’m assuming that’s what I want] or (3) Use Free Space [nope, I want to erase Windows and let the installer repartition however it wants to].
Then I choose Standard Partition (because I don’t know what LVM or Btrfs is) but it complains "Not enough free space on disks for automatic partitioning). I understand that the whole install will only need about 6GBs. Why should it even matter how much free space there is if it’s going to repartition the thing anyway?!?

I suggest that you fire up a any ‘linux live’ iso and as root

dd if=/dev/zero of=/dev/mmcblk bs=1M count=1&sync

(more robustly dd if=/dev/zero of=/dev/mmcblk bs=1M the whole device gets zeroed out)

This should reset the disk to a state where there is no UEFI or legacy MSDOS boot getting in your immediate way.

1 Like

Thanks, now it says mmcblk1 has 57.62 capacity and 57.62 free, so that looks better. And it lets me proceed to choose LVM.

But then it still says “Generating updated storage configuration” and “storage configuration failed: Not enough free space on disks for automatic partitioning”.

For some strange reason, the auto install insists on 64 GiB minimum, so 64 billion bytes is not enough. Partition manually and you should be ok.

IMO this is a bug. A system not recording calls (or with very low usage) can work fine with ~20 GiB. Either the minimum should be much smaller, or being below should be only a warning, not a fatal error.

1 Like

Before I was in the automatic installer, so I’ve gone back to the graphical, since that’s where I saw the option for me to configure partitions. It still says available space is 2014.5KiB and total space is 57.62 GiB, and I thought dicko’s suggestion should have reset it. Anyway, I go to add a new LVM mount point, and it asks for 2 things: Should I keep /dev/mmcblk as the mount point? And the desired capacity, I assume I enter “57.62 GiB” right?

In any case, when I try those two options, it failes to add new device. When I click, it says “not enough free space for new device”.

Lvm might find preexisting lvm’s try a full-on ‘disk scrub’

dd if=/dev/zero of=/dev/mmcblk bs=1M& sync

So I go to Advanced Options, then Recovery Mode, then Skip to Shell, then I enter
dd if=/dev/zero of=/dev/mmcblk bs=1M& sync
and it says:
[1] 1692
sh-4.2# dd: error writing ‘/dev/mmcblk’: No space left on device
1867+0 records in
1866+0 records out
1956696064 bytes (2.0 GB) copied, 1.01519 s, 1.9 GB/s

That bit is ok , you dd’ed zeros into the device without limit, when the device got full dd bitched.

But for whatever reason your device is only seen as 2G , Unfortunately there are unscrupulous folks out there that misrepresent the size of their ‘whatevers’

The linux kernel seas such devices by

cat /proc/partitions

Perhaps there is a kernel module from the manufacturer that might correct this situation ?

Got it.
Ok, so back to Manual Partitioning, the graphical installer still shows Available Space 2014.5 KiB, and when I add a new mount point at /dev/mmcblk of “50 GiB” which should be plenty below the total of “57.62 GiB” it still says it failed to add new device, again due to not enough free space.

Are you suggesting that this mini computer only has a 2GB SSD? I don’t think Windows could have been running with such a small drive.

No idea about your device, know a little more about linux

cat /proc/partitions

On my system like that, it shows:

major minor  #blocks  name

 179        0   61071360 mmcblk0
 179        1     204800 mmcblk0p1
 179        2     204800 mmcblk0p2
 179        3     409600 mmcblk0p3
 179        4   59772928 mmcblk0p4
 179       16       4096 mmcblk0boot1
 179        8       4096 mmcblk0boot0
 253        0   59768832 dm-0

Then you would need to zero out the root device /dev/mmcblk0

cat /proc/partitions
gives me:
179 0 60416000 mmcblk1
179 1 102400 mmcblk1p1
179 2 131072 mmcblk1p2
179 3 58428416 mmcblk1p3
179 4 1752064 mmcblk1p4
179 16 4096 mmcblk1boot1
179 8 4096 mmcblk1boot0
8 0 15633408 sda
8 1 2100224 sda1
8 2 8834 sda2
7 0 446520 loop0
7 1 2097152 loop1
7 2 524288 loop2
253 0 2097152 dm-0
253 1 2097152 dm-1

Then in your case zero out /dev/mmcblk1

(Interesting to find out what the 2Gb /dev/mmcblk is/was)

Thanks, now in Manual Partitioning, I can create /dev/mmcblk1 of 57.42 GiB and it has /boot/efi at mmcblk1p1 of 200 MiB. But now the installer complains that I have not defined a root partition (/) and I have not created a bootable partition, and I haven’t specified a swap partition. But I don’t see options in the UI to set any of those.

Can’t really help here is a I have no experience with this os or its ‘installer’ but you do need to specify root partition and the UEFI stuff if going ‘manual’, I would suggest however, that you might zero out your device again, and then do it over without pressing the manual button . . .

When I choose the Installation Destination, with “I will configure partitioning” then it has mmcblk1 selected and now it correctly shows 57.62 GiB free. But at the bottom it has:

Error checking storage configuration. …
Requested boot drive “mmcblk1boot0” doesn’t exist or cannot be used.
The following problem occurred on line 3 of the kickstart file:

However, when I have “Automatically configure partitioning” then it simply says “Not enough free space on disks for automatic partitioning”

I used FreePBX about 10 years ago, on some really old hardware, and it worked great. I’m surprised that the installer is in such poor shape in 2020.

Sorry, the kickstart is from the distro.

Signing off on this one, Bon Chance . . .

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.