Freepbx install on pcengines APU

I’m looking for a way to install FreePBX on a PCEngines APU1D. It’s just PC hardware but no VGA port. Any ideas?

I was able to do it on two APU boards using a “null modem” USB cable.
My procedure may not be the cleanest but it works and I didn’t have time to bring it to perfection.
In order to be succesful I had to use the USB stick image and tweak the Syslinux and Grub configuration to add serial support.

/syslinux/extlinux.conf:

add this as FIRST line:

serial 0 115200

then replace the default directive:

default freepbx-noraid-asterisk11

then on each of the “append” rows I removed “vga=normal” and added the following at the end of the line:

console=tty0 console=ttyS0,115200n8

Also remove the “menu color” and “menu background” directives

/syslinux/grub.conf:

remove or comment the following line:

[email protected]@

then add:

serial --unit=0 --speed=115200 --word=8 --parity=no --stop=1
terminal --timeout=15 serial console

And try to boot.
You should see the prompt “boot:”, press Enter and it will boot the “freepbx-noraid-asterisk11” image.
After installation it will reboot and on reboot (the first time you’ll have to wait for a few minutes) you’ll have to point your browser to the DHCP IP address it negotiated.
If your router doesn’t show the DHCP leases you can see if you find it via arp:

arp -al

or some other heuristic…

Ah: it goes without saying that you have to use a terminal emulation program to use serial port console. On Mac OSX you can open terminal and issue the following command:

screen /dev/your-tty-device 115200

Regards,
Marco

Thanks. I’ll try to source a serial cable. I was hoping to find a pre-built image I could flash to the internal mSATA drive but I’m not having any luck.

i try todo the same, but i am not able to change the config files from the usb-image. i tried to extract the img-fiel without success, i tried to mount the usbstick via linux with rw-option but the files are still readonly… any hint how to modify the files of the usb-stick/img-file?