FreePBX Install on NUC Intel Celeron dual core 2.4Mhz

Hi. I decided to move from a Beaglebone Black RasPBX into a FreePBX install. Seems like the Beaglebone can handle only 4 simultaneous calls. I may purchase an used Intel NUC Celeron dual core 2.4MHz 4GB RAM, which can support perhaps more simultaneous calls, but the device in view unfortunately has no CD-RW slot. It comes with Ubuntu pre-installed.

Question: how can I donwload and install the FreePBX + Asterix files package here and install them into my CD-RWless NUC Ubuntu machine?

I am not an Ubuntu expert (my pcs run on Windows 10). If there is a way to automatize the install that would be great. Any advice is welcome! :slight_smile:

Depending on whether you want to keep ubuntu on the machine or not.

  1. Don’t keep ubuntu:
    Download the freepbx iso, write it to USB drive, boot your NUC with the USB, and run the installation process.
  2. Keeping ubuntu:
    In this case I refer you to the docs

Good Luck!

1 Like

lesismore, thank you. Indeed, no need to keep ubunto. All I need is to have the FreePBX up and running as soon as possible. I will go for your first option. :slight_smile:

To create USB flash drive with bootable ISO you may use:

  • YUMI – Multiboot USB Creator
  • Rufus
  • WinSetupFromUSB

Please don’t do any of those things. We have a specific USB Image, that is downloadable from here:

You’ll see that we have explicit USB image links on the download page -

If you’re using the new Beta-2 SNG7 ISO (which isn’t actually released yet… but hopefully this week) you CAN use the ISO as a USB image using DD, or rufus or any of the above.

1 Like

Rob, many thanks for pointing out the right steps. :slight_smile: I am purchasing the PC this week, will download the specific USB image and install it.

1 Like

Rob, I purchased the hardware. My NUC has a micro SD slot and I have three questions:

  1. The FreePBX (USB) ISO can be installed into a 64Gb micro SD?
  2. How to make the NUC boot from the SD?
  3. I see there is available the FreePBX 14 Alpha. What is your guesstimate for the launching of the FreePBX 14 Beta or Stable Release? Will it take one month or one year? :slight_smile:
  4. Can I run the FreePBX installed on the 64Gb micro SD without need to install a SSD HD into the NUC? Will this affect performance?

Edit: I have a 240Gb SSD HD but it is much easier to install FreePBX on a microSD, hence my question above. But if the internal 240Gb SSD HD will improve significantly the performance, then I can use it instead of the micro SD.

Do you mean micro SD or do you really mean micro SSD?

1 Like

Hi Marble, thanks for pointing out! :slight_smile:

The new Distro explicitly will not install to removable media automatically. You’d need to do an Advanced Install and manually pick the destination.

Beta 2 is coming real-soon-now. I keep saying ‘this week’, but I keep finding bugs 8-(


Thanks Rob.

1 Like

Hello Rob. Well, need your help. My NUC has no CD ROM. On searching the FreePBX forums I found out Unetbootin. I ran it in my Windows 10 PC and it installed without issues the FreePBx 13 last ISO stable distro from here I plugged the USB into my NUC and after setting it up to boot from USB via F2, it will indeed start from the USB and present me a Unetbootin screen. I click ok, it will start loading (I believe, not sure) the FreePBX image into the NUC SODIMM RAM.

The loading is interrupted by a message “Not enough memory to load the specific image”. It happens that FreePBX is around 2Gb. The NUC RAM is 8Gb.

Please, any advice to solve this is welcome! :slight_smile:

If you’re trying to install from USB, you need to use the USB Image (.img) not the ISO (.iso)

I reallized my mistake earlier today. I tried the install using the USB image. It opens the FreePBX install menu, but will not install. On googling the error displayed when the install is interrupted, I found out it is related to defective RAM memory from the NUC. I returned the RAM to supplier and purchased another one. I hope to have it in my hands by tomorrow, will try again the install.

Any chance for a new distro beta release this week :slight_smile: ?

Ok. On trying the first install of the USB image into my NUC, it will stop install and throw a bad_area_nosemaphore error.
Solution: I found out this is probably due to a defective RAM memory card. Purchased another RAM card. The install goes well, the older RAM card was really defective.

But, somewhere into the Anaconda install there is a bug. The warning in red letters tell me “Store Activation Failed” and “Could not commit to disk /dev/sdb”. After further research, found out an old thread from 2011, it seems Anaconda or whatever the snake name :slight_smile: really has this bug. Seems like it was not solved up to now five years later.
Solution: Fortunately, the solution is easy: just reboot the NUC. Ctrl+Alt+Del it is, and the new Free PBX 13 install goes smoothly and without any hitch from beginning to end! :slight_smile:

So, I am now very happy and able to login into the FreePBX admin console. Really a good software, the User Interface much improved over the previous version. Not only user friendly, but much better designed. I will work tomorrow on the pbx settings. I post here how I solved the two issues I faced during install. Perhaps this helps other FreePBX users. I just need information about the firewall, will post in another thread.

Many thanks! :slight_smile: