FreePBX incorrectly removes last FXO channel number

PBX in a Flash Version = 1.7.5.5
FreePBX Version = 2.8.0.4
Running Asterisk Version = Asterisk 1.8.0
Asterisk Source Version = 1.8.0
Dahdi Source Version = 2.4.0+2.4.0
Libpri Source Version = 1.4.11.5
Operating System = CentOS release 5.5 (Final)
Kernel Version = 2.6.18-194.26.1.el5 - 32 Bit
Ran update-scripts :No
Ran update-fixes :No
Ran update-source :No
Analog Card = Digium TDM400P

When configuring DAHDi Extensions, there is a drop-down list for selecting the channel number. In Firefox you cannot select the last channel on the card, but in IE you can.

Even with IE allowing the last channel on the card to be selected, FreePBX will still configure /etc/asterisk/chan_dahdi_additional.conf without the last channel when settings are applied. The resulting file follows. (With my manual addition of channel 3 at the end of the file.)

/etc/asterisk/chan_dahdi_additional.conf:

;--------------------------------------------------------------------------------;
; Do NOT edit this file as it is auto-generated by FreePBX. All modifications to ;
; this file must be done via the web gui. There are alternative files to make ;
; custom modifications, details at: http://freepbx.org/configuration_files ;
;--------------------------------------------------------------------------------;
;

;;;;;;[4001]
signalling=fxo_ks
pickupgroup=
[email protected]
immediate=no
echotraining=800
echocancelwhenbridged=no
echocancel=yes
context=from-internal
callprogress=no
callgroup=
callerid=device <4001>
busydetect=no
busycount=7
accountcode=
channel=>1

;;;;;;[4002]
signalling=fxo_ks
pickupgroup=
[email protected]
immediate=no
echotraining=800
echocancelwhenbridged=no
echocancel=yes
context=from-internal
callprogress=no
callgroup=
callerid=device <4002>
busydetect=no
busycount=7
accountcode=
channel=>2

;;;;;;[4003]
signalling=fxo_ks
pickupgroup=
[email protected]
immediate=no
echotraining=800
echocancelwhenbridged=no
echocancel=yes
context=from-internal
callprogress=no
callgroup=
callerid=device <4003>
busydetect=no
busycount=7
accountcode=
channel=>3

When setting are applied in FreePBX it removes the number ‘3’ from ‘channel=>’ at the end of the file. If I add it back by hand, and restart DAHDi, the driver loads properly. Without, of course, the complete card does not work.

Channel 4 is FXS.

Any ideas are welcome… Thanks

I am not much of a asterisk guru, so I cannot answer if it is from the contributed_modules directory. This is a fresh install of PBX in a Flash with the additions of the latest from Nerd Vittles. I do know this has been the same result in two if my installs.

I will re-post this as a bug. I thought I had read something about this before, but I was unable to locate it again.

Thank You Philippe for your feedback

from the description, sounds like a bug.

Go ahead and file a bug report. I assume this is in conjunction with the dadhi module from the contributed_modules directory?