Freepbx in the office has to call extensions even when there is no connectivity

I have a freePBX that is installed directly at the office, when there is no connectivity “unfortunately it happens occasionally due to the unfortunate zone” it is important that calls between extensions continue to work without difficulty.
Unfortunately, when there is no internet, the calls work but after several seconds.
Looking at the log you can see the time-out …
Is there a way to configure freepbx to start calls quickly even when there is no internet?

I tried to put the hosts file the resolution of the domain name of my sip provider but nothing changes …

I’ve also tried putting IP address instead of host in trunk registration strings but it seems to have no positive effect …

I also changed in the trunks by inswering srvlookup=no
But even so something doesn’t change I always have to wait a few seconds …

I’m starting to think about installing bind so I get my own DNS server and maybe fix it.
I’d like not to do that and find a better solution.

I open a new post because I want to see it from another perspective …

My FreePBX if it has no internet does not allow calls between extensions!

I don’t like it …

So what do I do I see the logs and I understand that Asterisk is waiting for the DNS !!!

So what do we do?

Let’s set up a DNS caching with dnsmasq …?

Have I never made tutorials to suggest? :slight_smile:

I’ve moved the topic over here because I didn’t see the need to open another topic for the same fundamental thing and issue.

This problem is caused when chan_sip loses DNS. The best solution is to just disable chan_sip, and use PJSIP exclusively for extensions and trunks. Anything else like DNS caching etc is just a band-aid.

Thanks as soon as I have so I’ll try and update the post

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.