FreePBX in Cloud Hosting (static IP-Address) + Snom Device without VPN (pjsip)


(MK) #1

dear team,

i have currently always worked with openVPN + freepbx behind a firewall.
that means from phones i can ping directly freepbx and from freepbx to the phones also.

now i want install a new freepbx what is placed direct in cloud (static ip-address).
then with the endpoint manager i will do a rollout for my snom phones.

so my main question: is this setup good or can this work?

for my tests:
currently i tried it several times but my phones (snom d715) always goes from unavailable to not in use.

if i then do outgoing call from snom phone, the phone writes unregistrered.

but i have configured the firewall what is onboard in freepbx good. also have tried to disable the firewall.

is this setup good or not recommended? how i can get this work “stable”? is there a setup guide how i should configure the freepbx + endpointmanager? or is it better to use openVPN instead of direct connection?
have tried it with max contacts = 10 but only used currently the 1 contact with my snom phone.

that means: my freepbx = in a datacenter with a public ip address,
and my phones are in several different NAT networks behind. autoprovision active (http port 84)

thank you so much.


(Greg Snover) #2

70% of our boxes are in this exact configuration - it works well. None of our phones are VPN’ed - all direct connect.

The Firewall included with FreePBX is VERY flexible and seems to be very good at protection.

Go for it - it works!


(Jared Busch) #3

You are doing something wrong someplace.

I am certain that a large portion of FreePBX system are hosted on a public service someplace.

I know ~75% of my installs are.


(Greg Snover) #4

Sorry - I was commenting on the Concept, not the implementation - yes, if you are having problems with this setup, you have something mis-configured.

Start posting your settings for the Firewall (anonymized of course), SIP and PJSIP settings and Endpoint Manager and we should be able to spot what is wrong.

But it really does work!


(MK) #5

thank you so much for all your answers.

i have fixed my issue. this setup without vpn is much easier as with vpn configuration.

many greets