Freepbx floods syslog

while I found some conversation about how to send freepbx logs to syslog, I have somehow the opposite problem. My syslog is flooded every minute with cronjob status from freepbx, as it looks (see below)
That isn’t very useful and just hinders me to see relevant data in syslog. Before I start to filter in rsyslog.conf, is there a way to block that at source somehow?


Mar 13 12:24:02 autohome CRON[26270]: (asterisk) CMD ([ -e /usr/sbin/fwconsole ] && sleep $((RANDOM%30)) && /usr/sbin/fwconsole job --run --quiet 2>&1 > /dev/null)
Mar 13 12:24:02 autohome crontab[26288]: (asterisk) LIST (asterisk)
Mar 13 12:24:02 autohome crontab[26290]: (asterisk) LIST (asterisk)
Mar 13 12:24:03 autohome crontab[26292]: (asterisk) LIST (asterisk)
Mar 13 12:24:03 autohome crontab[26294]: (asterisk) REPLACE (asterisk)
Mar 13 12:24:03 autohome crontab[26296]: (asterisk) LIST (asterisk)
Mar 13 12:24:03 autohome crontab[26298]: (asterisk) LIST (asterisk)
Mar 13 12:24:03 autohome crontab[26300]: (asterisk) REPLACE (asterisk)
Mar 13 12:24:03 autohome crontab[26302]: (asterisk) LIST (asterisk)

Not sure where that is set but have you turned off all the extra logging in Fpbx > Settings > Advanced Settings?

It’s near the bottom in the section called “System Setup”. Disable FreePBX Log, Log Verbose Messages, PHP Error Log Output etc. I have never needed any of that stuff unless I am troubleshooting code and disable all of it on any new install.

Also, go into Settings > Asterisk Log File Settings > Log Files and turn off everything except “Error” in all files/logs. It just fills up storage and loads down the server with excessive logging. Again, I am of the opinion all of that should be disabled by default. Disabling all of that is one of the first things I do on any new install. It’s usually only helpful to have that stuff enabled in special cases for short periods of time, like when you are trying to troubleshoot something.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.