FreePBX firewall configuration issue - Please assign interface 'eth0' to a zone

I’m trying to get the FreePBX 13 firewall setup, I’m getting an error that I need help with. I’m pretty sure I’ve done what’s needed to fix it, but the error is still there.

My settings

Is this incorrect?

I have restarted freepbx and disabled/enabled the firewall after the change.

Having another issue that I thought I solved.

Thought I solved with this