FreePBX Firewall Ban Even Though Whitelisted

Good Morning,

FreePBX Distro 12.7.8-2302-1, Asterisk 18.17.1

After restoring a backup to a new instance i am losing access from my local network to the GUI and SSH.

PBX Works ok, Incoming Outgoing Calls and all extensions that are already registered.

Can’t register new when this happens or register an extension that has been offline.

Since it was a backup that was restored, everything seems to be in order with the firewall subnets.

How can i see if my problem is indeed the firewall banning me or something else?
I have checked the fail2ban log but not sure if i understand it.

I have tried different pc’s to log from they all don’t respond, even tried a different subnet through my VPN where i usually logged on fine and still doesn’t work.

The same problem happened last night and when i checked it in the morning it was ok on its own.

When it didn’t work a couple of days back a reboot solved it.

Mentioning again that i only have access problems to both SSH and Web GUI.
PBX Works fine besides that.

Any ideas how to troubleshoot this?

i don’t think that this is of use to me. i already have this enabled and as mentioned above after my reboot the problem solves itself even after the 5 minute mark of disabled firewall.

It does it whenever it wants usually after 12 hours or so for example yesterday it was ok in the morning and when i tried to access my gui in the evening i lost connection.

When i came back in the morning it was working ok.

A little update, locally i see the 0.0/24 range is accessing the ssh and web gui.

My remote range which is fails to do so.

If i disable the firewall the problem resolves.

If i enable the problem comes back immediatelly.

I have check if the 5.0/24 is banned but it says that nothing is banned.

New Update, i have uninstalled and reinstalled the firewall module and resetup everything from scratch.

Seems to be going ok for now mind you it happens on and off.

Will keep posted

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.