FreePBX extensions > DIGIUM OPTIONS?

Hi guys,

Using FreePBX 12.0.76

What happened with the DIGIUM PHONES options in the extensions configuration ?

I just created a a new extension.

I use to be able to specify the line label, and other useful stuff there.

Now the whole DIGIUM PHONES section doesn’t seem to even exist?

Please help.

do you have the digium phones module installed/enabled?

Same for me - I have a server where the digium phone options are under extensions, but just did a new install and they are nowhere to be found - and additionally the digium phone config module does not make changes to the phone configs properly. For instance I tried to change the label on a phone, hit reconfigure and the phone kept the same name, factory reset the phone and it still had the same name. I had to manually change the label in the digium_phones_extension_settings database table for it to actually update as it appears the module isnt actually updating these entries, because these entries are supposed to be modified within the extensions section of freepbx and since those settings are missing there is no way to change them.

It’s a bug. We’ve been told that rolling back to version fixes the regression. We’ll get this fixed.

Dumb question but how do you ‘roll back’?
duh - just figured it out

Hi! So, how do you rollback the Digium Phones Config to version

Ok. Duh myself. sorry for wasting everyone’s time!!

I have distro; 6.12.65-29 Freepbx 12.0.76.
Asterisk Vers. 13.5.0.
In Admin module; when I want to update commercial modules, it says,“Enabled; Not available online”.

I tried to update digium_phones module. nothing happened.
I uninstalled and removed the module. Again I have the same problem.

In ssh when I write; “amportal a ma download digium_phones”

I have an error:
"The following error(s) occured:

  • Retrieved Module XML Was Empty"

when I write: "amportal a ma upgradeall"
it says;

Fetching FreePBX settings with gen_amp_conf.php…

no repos specified, using: [standard,commercial] from last GUI settings

Up to date.

Removing any dangling symlinks
Dangling symlinks removed

but at the end I can not update commercial modules.
Help, Please.

Plus, I can not roll back any of the modules in Module Admin.

it is SOLVED. Thanks