FreePBX Endpoint Manager (Commercial) and Dial now rules

Using the FreePBX Endpoint Manager (Commercial) and the dial now rules. All of them seem to work fine except for calling a phone number.

Yealink T22P

For example, here is my config: 911|811|1xx|2xx|1NXXXXXXXXX

911 - Emergency
811 - Vitelity 911 test
1xx - Internal
2xx - Internal
1NXXXXXXXXX - outside

All are working except outside dialing. Any ideas?

try “x” with lowercase;
like 1Nxxxxxxxxx

Good idea.

I tried it but still not working.


The reason you cannot call out is because as soon as 1xx is entered, the call matches the internal pattern and is sent with no delay.

You have to program the 1xx to delay for a few seconds (3?) to wait for more digits. Its a phone configuration (not freepbx)

Or else you would need to make patterns that dont overlap.

For example, you could have 9 as a prefix for outbound calls

Then your plan would be 91nxxxxxxxxx

And then program freepbx outbound route to strip the 9 before sending to trunk

I dumped all my 1xx ext and changed it to this:


Still not working.

What is your outbound route settings/pattern? What happens when you dial? Does it send the digits after you enter them or does it wait for timeout? Does it give a busy tone or play a msg?

Makes no attempt to send digits, can be forced by using # after the number.

Dial Pattern(s):

Works find when handset is picket up, but when using headset or speaker phone doesn’t dial.

Does it work when forced by using #? And the call completes?

And it also works perfectly fine when handset is lifted? Strange.

Post your phone config for us

Tell me exactly what you need posted here please. Thanks for your help.

Unfortunately, im not familiar with the Endpoint Manager module or the config for yealink phones. But i know that there is a problem with the dial plan in the phone config. Hopefully someone else will post to take it from here.

1 Like

Thanks! I appreciate your help & happy holidays.