FreePBX Endpoint Commerical Module spa504G.cfg


I use the commercial Endpoint module to provision our Cisco SPA504G phones however I have a small problem when I first provision a new phone. The phone gets stuck during provisioning.

I found the cause of the problem to be in /tftpboot/spa506G.cfg.

If I change the line which reads

then factory reset the phone, the phone loads and provisions correctly.

As this file is generated by the Endpoint module, the changes are overwritten each time “apply changes” is clicked in the FreePBX GUI.

For the life of me, I cant find where in the GUI to be able to set the line above so the correct protocol is generated by FreePBX.

Can someone please help?

Check your template, is http or tftp selected?


Thanks for the quick response!

I’ve checked my templates but they are all set to TFTP.

Is there a global template setting or something which is called first of all?


That is the only thing that sets them. Sounds like a bug. Are you sure you are on the latest EPM

I am using version 13.0.99 of Endpoint Manager which I believe to be the latest. FreePBX version is 10.13.66-16

Strangely, I have another almost identical system (10.13.66-11) with EndpointManager (13.0.99) and this machine works as expected.


It looks like it is working for me using EPM You can upgrade to edge with:

fwconsole ma --edge upgrade endpoint

Then rebuild your configs and test.

Thanks! Will give that a go over the weekend.



Just to quickly update - This issue appears to be resolved now :slight_smile:

Thank you.