Freepbx - Email issue

Hello,

I have purchased the Sysadmin Pro module, mostly because I’m appreciative of the work performed to provide us with Freepbx, and partly because I wanted to save the hassle of playing in configuration files.

Unfortunately, I have been unable to make the email work so far.

Currently, Debug shows that my emails are bounced. Here are a few logs:

May 20 12:37:38 freepbxV5 postfix/pickup[16035]: CF42010DF731: uid=995 from=
May 20 12:37:38 freepbxV5 postfix/qmgr[16036]: CF42010DF731: from=<[email protected]@mydomainname.com>, size=532, nrcpt=1 (queue active)

As you can see, freepbx is adding a “asterisk” prior to the email I’d like it to send it from.

I have no clue where the “asterisk” comes from. If you guys can point me in the right direction, don’t hesitate.

Thanks,

Frank

If this is a voicemail email, check the Voicemail settings from string, otherwise, check in Sysyem Admin notifications section

Hello PitzKey! Thank you for taking the time to try and help me: it is truly appreciated. Notification wise, I checked and nothing there shows asterisk.

Nothing is configured in the voicemails either.

For the record: I get the error when I use the “debug” of the email config menu. After trying a few things, I noticed that my “[email protected]” did receive some messages from the PBX (module updated for security reasons) - it feels like it’s a bug in the… debug!! :wink:

Let me know if you think of somewhere else I should look!

Thanks again

Frank

Show the actual Email Setup from System Admin.

Hi!

This looks like you put an email address in either My Origin or My Domain of Email Setup.

These are, respectively, Postfix myorigin (http://www.postfix.org/postconf.5.html#myorigin) and Postfix mydomain (http://www.postfix.org/postconf.5.html#mydomain), neither of which are supposed to be filled in with an email address.

I don’t have the most standard of setup email wise (part of my job used to be setting up and taking care of mail servers) but I think in that to get a more sensible From address you might want to set From Address in Notification Settings and put back the default values in Email Setup.

Good luck and have a nice day!

Nick

Marbled: you are correct.

I replaced the information in the “My Origin” box from an email address to my domain only.

Debut still failed… but I noticed that it still tried to use "[email protected]" as an address, so I went and added it to my office 365 profile. Sure enough, the next attempt to use “debug” worked.

It still gave this error message:

May 26 12:27:45 freepbx postfix/smtp[21858]: connect to smtp.office365.com[2603:1036:302:834::2]:587: Network is unreachable

If I could get rid of that error message, i’d be even more confident…

Thanks!

Hi!

Ok

Have you tried setting the From Address in Notification Settings to [email protected]?

Does your firewall permits your PBX to talk to Microsoft’s servers?
Using the SMTP submission port? (port 587)
Looking at the IP address of office365.com servers I see that it tries to use IPV6, is this properly setted up on your network/firewall?

If not, you might want to disable it on your FreePBX box, see How to disable IPV6 [SOLVED]

Good luck and have a nice day!

Nick

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.