FreePBX Distro V1.86.29.55 Install Problem - Dell OptiPlex 390 System


Ive just downloaded the latest Freepbx Distro inorder to install on a New Dell PBX System

Del Spec
OptiPlex 390 Desktop
Core i5-2400, 3.1GHz, 6M, VT-x
4GB,Non-ECC,1333MHz DDR3,1X4GB
500GB SATA 3.0Gb/s and 16MB Data Burst Cache
Integrated Video,HD Graphics 2000

The ISO boots successfully, however when choosing any of the options (Including Memtest) the system hangs

Thinking it was possibly a problem with missing drivers, i tried installing CentOS5.5 from a install disc… Similar problems, system just hangs

I then downloaded CentOS V6 minimal install ISO, this version installs and runs without any issues.

I therefore believe the current Distro maybe missing some drivers, possibly for the SATA had drive.

Has anyone else seen any similar problems ?

Is anyone able to offer any advise as to how i can verify this problem, and possibly resolve ?

Thank You

I just did a distro install yesterday on a generic box and it worked fine.

Thanks for your reply,

I too have tried this on a different box, and it works OK, I therefore think the problem maybe related to the Dell OptiPlex 390 System, and needing different drivers ??

Sometimes, CentOS doesn’t have the drivers for a particular system. If it doesn’t, you can spend days trying to find out if someone’s written one for the unit you’re trying to install on, or you can give up and try it on another machine.

As a workaround, you could install VMWare’s ESXi Hypervisor 4.1 or 5 on your Dell and then install the FreePBX Distro as a virtual machine, but that’s not recommended for a production system, and those in the know will chastize me for suggesting it. :slight_smile:

I ran into the same issue (although I was trying to install the beta).

The way I finally got around it (just finished a few minutes ago) was by using a CentOS 5.7 DVD and at the boot: prompt I typed in:

linux ks=

I got the ks= portion by reading the isolinux.cfg file and in my file it had:

label FreePBX Distro
menu label ^FreePBX Net BETA Installer 64Bit Version - WARNING: Erases hard drives!
KERNEL vmlinuz
menu default
append vga=normal initrd=initrd.img ramdisk_size=32768 ks= ksdevice=eth0 kssendmac

so I just took the part that says ks=… and used that.

Hope that helps.