FreePBX | Register | Issues | Wiki | Portal | Support

FreePBX Distro SSD issue


#1

Just installed FreePBX on a 60Gb OCZ Agility SSD, which is a part of an OpenVox IX130-B - 1.6 Ghz Atom with 1GB DDR2 system with an A810P card with 8 FXO ports

It installed fine & got the system all configured; worked for about a week, it would then randomly freeze reporting a bad EIP value and cause a kernel panic after a restart it would work fine for a few days and same thing would happen with increasing frequency to the point now that it fails to load on semi random service on start up, the current error is as follows:

EIP: [] radix_tree_lookup+0x46/0x50 SS:ESP 0068Ff7fafda8
<0>Kernal panic - not syncing: Fatal exception

The other thing that is shown during startup is that it is having an issue writing to /tmp.

Is this possible caused because it is installed on SSD

Any help would be appreciated

Thanks
Tom


#2

No one has any idea? I have searched the forum for ‘Kernal panic - not syncing’ and got nothing. Is it a CentOS issue? We installed FreePBX as we would normally off CD. The SSD was not formatted any differently. Should it be?


#3

You don’t have to use any special filesystem on an SSD. Just sounds like you have a bad drive.


#4

Or a bad motherboard or bad memory, cpu, fan or flaky physical connections, each and all can cause the dreaded “Kernal panic - not syncing”

(been there, done that :wink: )


#5

Thanks - We are in the process of testing the drive now. Is there no way to narrow it down from the error codes? The memory test passed ok.


#6

Not really, to pun a little, “There many a slip twixt the cpu and the disk”

sysstat/sar is often a good tool to catch such slips (and many others) preemptively.


#7

Ok thanks, will post the outcome when we get there.


#8

Take a look in /var/log/messages for possible drive errors, also dmesg.

Lastly run smartcontrol, lots of info on your drive: Let’s assume it’s dev/sda

smartctl -Hc /dev/sda

smartctl -A /dev/sda

smartctl -a /dev/sda

smartctl -l error /dev/sda

smartctl -l selftest /dev/sda

That will keep you busy for awhile!


#9

Ok so we ended up replacing the drive with a 60GB Corsair Force 3. We reinstalled FreePBX and left it running for a week to see how it went. Everything seemed fine, so we continued with configuration. We ran dahdi_genconf but it turned out dahdi was not seeing our OpenVox A810E. We followed the instructions here: http://wiki.openvox.cn/index.php/OpenVox_A810E_DAHDI_en and updated dahdi to this release: http://downloads.openvox.cn/pub/drivers/dahdi-linux-complete/releases/1.3.5/openvox_dahdi-linux-complete-2.6.1+2.6.1.tar.gz

Once we completed make we were able to run dahdi_genconf and asterisk was seeing all 8 channels. 5 minutes later we received a kernel panic. We rebooted and tried interactive startup. We’ve found that everytime the Kudzu service starts it will crash straight away with a kernel panic. If we do not start Kudzu, sometimes we get further, yet it will eventually crash with a kernel panic.

So two failed drives seems unlikely… what else could be causing this? Could it be the A810E? It seemed to be running fine until we loaded the updated Dahdi drivers.

Would appreciate any help. We really need to get this system going asap.


#10

It’s not Kudzu, it’s the DAHDI drivers. You have to build them against the Kernel source. Linux isn’t like Windows that you can run binaries across kernels.


#11

Could you possibly elaborate re building them against the Kernel source?
Is openvox_dahdi-linux-complete-2.6.1+2.6.1.tar.gz the wrong package? We used that one as it is the latest… There were no errors during make, make install or make config.

Thanks.


#12

When you downloaded that package you did the whole configure/make/make install process?


#13

Yes, we followed the instructions on the Openvox Wiki which state:

cd /usr/src/dahdi-linux-complete-XX

make

make install

make config

There were no errors.

After that we ran:

modprobe dahdi

modprobe opvxa24xx

dahdi_genconf

We then ran amportal restart and ‘dahdi show channels’ and all 8 channels were listed.


#14

That is odd, please post output of ‘yum list | grep -i kernel’


#15
# yum list | grep -i kernel

kernel.i686 2.6.18-308.4.1.el5 installed
kernel-devel.i686 2.6.18-308.4.1.el5 installed
kernel-headers.i386 2.6.18-308.4.1.el5 installed
wanpipe.i686 3.5.26-kernel.2.6.18.308.4.1.el5.dahdi.2.6.1
kernel-PAE.i686 2.6.18-308.4.1.el5 updates
kernel-PAE-devel.i686 2.6.18-308.4.1.el5 updates
kernel-debug.i686 2.6.18-308.4.1.el5 updates
kernel-debug-devel.i686 2.6.18-308.4.1.el5 updates
kernel-doc.noarch 2.6.18-308.4.1.el5 updates
kernel-xen.i686 2.6.18-308.4.1.el5 updates
kernel-xen-devel.i686 2.6.18-308.4.1.el5 updates
wanpipe.i686 3.5.27-kernel.2.6.18.308.4.1.el5.dahdi.2.6.1
yum-kernel-module.noarch 1.1.16-21.el5.centos base


#16

Well they all match so something is up. Can you try another motherboard? Your luck is not so good.


#17

Tell me about it… its been an absolute pain. I am emailing OpenVox now to see what they think. This is our first OpenVox product so we don’t have any spares… hopefully we can get a replacement.


#18

I have had few bad cards from them. I would try it in a different computer first.


#19

Ok we had Openvox support access the system and they seem to have resolved the issue. They edited /etc/dahdi/system.conf and commented out all the lines containing: echocanceller=mg2,#

Since then we have not had a single kernel panic. I went to configure and test the PSTN line to see what quality was like and now it seems FreePBX is broken.

Browsing to the webgui gives this error:

FATAL ERROR

fatal error reading freepbx_settings

Trace Back

/var/www/html/admin/libraries/freepbx_conf.class.php:219 die_freepbx()
  [0]: fatal error reading freepbx_settings

/var/www/html/admin/libraries/freepbx_conf.class.php:192 freepbx_conf-&gt;__construct()

/var/www/html/admin/bootstrap.php:101 freepbx_conf::create()

/etc/freepbx.conf:9 require_once()
  [0]: /var/www/html/admin/bootstrap.php

/var/www/html/index.php:18 include_once()
  [0]: /etc/freepbx.conf

Running amportal start at shell produces this error:


Fetching FreePBX settings with gen_amp_conf.php..
/usr/local/sbin/amportal: line 49: [FATAL]: command not found

/var/lib/asterisk/bin/freepbx_engine: line 98: [FATAL]: command not found
**** WARNING: ERROR IN CONFIGURATION ****
astrundir in '/etc/asterisk' is set to  but the directory
does not exists. Attempting to create it with: 'mkdir -p '

mkdir: missing operand
Try `mkdir --help' for more information.
**** ERROR: COULD NOT CREATE  ****
Attempt to execute 'mkdir -p ' failed with an exit code of 1
You must create this directory and the try again.

I checked /etc/asterisk/asterisk.conf and the astrundir line is:

astrundir => /var/run/asterisk

I cd to /var/run/asterisk and ls -l which produces:

srwxr-xr-x 1 asterisk asterisk 0 Aug 28 14:09 asterisk.ctl
-rw-r--r-- 1 asterisk asterisk 5 Aug 28 14:09 asterisk.pid

Cross checking this with another system and it seems ok.

I have searched the forums and found similar issues but nothing has worked so far.

I also ran the latest Distro update script again to see if it would reinstall any dependencies. We are running 1.815.210.58-1

Any ideas? So close…


#20

I would not blame FreePBX (or Digium), OpenVox are not “mainstream” with Digium, perhaps due to copyright infringement problems ;-).

So because they are not “mainstream” and have to write their own “patches” (mostly to do with BUS ID’s) against dahdi due to that uncomfortable status quo , whether you agree ethically with what they make and market is another question, but if as you say you gave them access and it now “doesn’t work”, I would suggest you shout loudly and immediately with them.

You get what you paid for, In this case an incompetent OpenVox engineer subverting your Digium written Dahdi driver, there is no other explanation. Dahdi is software that is not even part of Asterisk never mind FreePBX. That he FU’ed you up outside any assumed bailiwick you gave him does not surprise me though.

again JM2CWAE, been there done that too.

(but you did save yourself 50 bucks though, so feel good about that, Bain does)