FreePBX distro network not working

Hi everyone,

I really need your help. I am desperate and not able to solve this problem.

Looked at all centos documentation,forums and blogs. Can’t figure out what’s missing here.

I have 2 server boxes (brand new).

First I installed the freepbx Stable-1.813.210.58 distro 64 bit to the 1st server (followed exactly from the installation guide). All okay and managed to login. But I can’t seem to ping to or even my gateway I thought probably my network card had issue.

Then I tested the same on the 2nd server box, same problem happens.

In order to verify this, I installed HylaFax distro (got this working on other machine) on the same boxes above. It works, I can’t access to the hylafax installation website and also within it I can ping to any sites.

My settings as follows:-


search local
nameserver (tried opendns, makes no difference too)

route -n | … | … | (added this via route add default gw

IPADDR= (tried different IP too)
ONBOOT=yes (tried no too)
BOOTPROTO=none (tried static too)
GATEWAY= (removed this makes no difference)
NM_CONTROLLED=yes (test no or remove too)


/etc/hosts localhost freepbx localhost.localdomain localhost
::1 localhost6.localdomain6 localhost6 freepbx (copied similar to hylafax installation which work, but no differences)


… Destination Host Unreachable

… Destination Host Unreachable

ping (works here)

ping (works, same IP with server)

at the same time, i flushed IPtables or stop the service makes no differences too.

Note: I tried other flavors like Elastix and not getting it to work either. Just why is HylaFax distro working? If not mistaken, it’s using Centos 5.8 probably not too far away from freepbx centos distro.

Anyone mind to help? Thanks so much.

For better clarity, check the screenshots below.

please note that I tried both elastix 2.3 and freepbx Stable-1.813.210.58 distro 64 bit. Same problems.

i) iptables & disabled (ping still can’t work)

ii) ping fails

iii) selinux disabled

iv) orders bind

v) /etc/sysconfig/network-scripts/ifcfg-eth0

vi) ifconfig

vii) /etc/resolv.conf

viii) /etc/sysconfig/network

ix) hosts

x) route -n

xi) mii-tools eth0

any help? thanks.

Well certainly you have covered the basis and done a good job of communicating what you have done.

The odd thing is no rx or tx packets.

What does ‘miitoll eth0’ show?

Also 'arp -a" after you tried to ping your default gateway please.

Hi SkykingOH,

I can’t use miitool or mii-tool (command not found), instead i use “ethtool eth0”.

I got link detected: no as below.

I tried “arp -a” after trying to ping. Check below.

any solution to fix this and make it up?

thanks in advance.

I bet the light is not on the NIC or the switchport. Sounds like a bad cable, NIC or switchport to me.

yes the led is blinking, i replace to other network cables too.

i replace to other ports too, switch all okay coz my others can ping and other hylafax server is up and running fine. can ping too.

FYI, the same box worked with HylaFax distro (centos 5.8). But not on elastix or freepbx (centos 5.7). Couldn’t be the hardware or cables, i believe.

any other way? thanks.

Have you replaced the NIC itself?


Last question, is there any other network interface that might have the same MAC address on your LAN. Not supposed to happen but once in a while it does and can cause havoc.


I’d want to make sure new working was working at that particular location. Can you plug in a laptop that you know is working at that exact location using the same cable, etc?

I know this is a dumb question…but is your NIC registering as eth0. Is your network providing DHCP. And a dumber question still, but we’ve all done it…but is your network really 192.168.1.x?

Also, try replacing your eth0 with the following:


Restart the network then do an ifconfig and note the info returned.

Yes, remove the HWADDR line. That is the MAC address of the NIC.

If you have that fat fingered in any way exactly what you described would happen.

Since you have only one NIC the HWADDR line is doing nothing, it is used to bind interfaces to instances.

Yes. Take out the HWADDR. Unless you have multiple NICs it’s not needed. I think it is in error anyway. I’ve always used all caps for the letters there, you have a lower case “c” in the “9c” octet. Not sure if caps are needed there now, but they were in the dim and distant past, so that’s the way I’ve always entered them. Strictly, there is no Lower case in hex notation. ( in the very early days of computing, when hex notation was devised, terminals and ttys didn’t display LCD).

I have looked at multiple systems that I have with dual NICs. Some of the hardware addresses are in uppercase and some lower case. Some systems have one address in upper and one in lower. I do not think the case matters.

I would try to remove the hardware address line but it probably will not matter.

Do you have a small router that you can setup as a DHCP server. Plug the system into that router and see if you get an IP address.

Thanks Alan for the clarification. I’ve just used the UC notation for so long, that I never gave that a second thought! Old habits die hard!