FreePBX | Register | Issues | Wiki | Portal | Support

Freepbx distro install fails with file conflicts on new ibm x3250 server


#1

I have been trying to install the latest freepbx distro on a new ibm x3250 server.

The distro version is from http://downloads.freepbxdistro.org/ISO/FreePBX-Distro-Net-1.8.2.0.iso.

The installation process ends after the / filesystem is formatted.

Looking at the error messages I have:

“There was an error running your transaction, for the following reason(s): file conflicts”

on the console there are numerous errors such as:

ERROR : file conflicts: file /lib/modules/2.6.18-194.17.1.el5/dahdi/xpp/xpd_pri.ko conflicts between attempted installs of kmod-dahdi-linux-2.4.1.2-1_centos5.2.6.18_194.17.1.el5.i686 and kmod-dahdi-linux-2.5.0-1_centos5.2.6.18_194.17.1.el5.i686

Is there something wrong with the net downloads at the moment, or is the freepbx distro incompatible with new 64 bit servers?


#2

I’ve the same problem (Version 1.8.2.0).


#3

It must be caused by an update, installation is also broken on a server which used to work.


#4

Everything is find and dandy right up to package installation when it fails to download anything at all. Failure message is the same, “There was an error running your transaction, for the following reason(s): file conflicts”


#5

I’m having the same issue since last night on my installations


#6

I made it work by hijqcking kickstart.freepbxdistro.org to redirect http://kickstart.freepbxdistro.org/1.8.2.0/index.php to a local server and comment out any package in the dahdi section.
I think only kmod-dahdi-linux and dahdi-linux-devel are causing problems.


#7

Thanks for the advice, that worked.


(system) #8