FreePBX | Register | Issues | Wiki | Portal | Support

FreePBX Distro Hangs at Install with Blinking Cursor


(Collin Cronin) #1

Hello,

Noob here so bare with me as I ask dumb questions. My company ordered 2x PBXact System 100 appliances to be configured for HA. During the course of our testing, we began to receive alerts in the dashboard, that files were missing. I attempted to upgrade to SNG7 to reinstall the missing files then discovered that SNG7 was unsupported in HA.

At this point the GUI is unavailable and an apache test page is displayed when typing the IP into a browser. The CLI is still available but doesn’t display the expected PBXact login header just the hostname login.

I am following the PBXact System 60 and 100 Recovery Wiki post to repair an appliance to the HA Install using the included usb recovery key. For whatever reason after selecting the HA Install the process displays:
Loading vmlinuz…
Loading initrd.img…ready.
Probing EDD (edd=off to disable)… ok

After this the screen flashes then hangs on a blinking white cursor.

My Questions:
Is the recovery key the proper way to reinstall the HA Install?
What would cause the blinking cursor hanging screen?

Any help would be greatly appreciated.


(Dave Burgess) #2

Silly question - have you reached out to Sangoma with a ticket? Seems to me this would be a commercially supported configuration.

The more concerning issue is that you have files that are disappearing. That’s unusual.


(Mike Ledbetter) #3

I managed to fix it on my system. I dropped back to the prior version that does boot, let it boot to the CLI prompt and made sure I could login, then I logged in to the admin GUI, ran all updates for the system and modules, it crashed in the process, so I installed the OEMBRANDING module as it suggested, then ran
amportal chown
amportal a refreshsignatures
amportal a reload, then rebooted.

It works great now.