FreePBX Distro 64Bit

We have a brand new 64 bit version of the Distro. This is considered beta and is based on the same Beta 32 Bit version of

You can download it from

Remember this is a Beta Version and our first 64bit version. Please let me know any issues.

The HP N40L I used loaded up just fine with one exception. It seems manager.conf wrote out the admin password as amp111. One I made sure it was the same as in amportal.conf the following error was gone:

[FATAL] Unable to connect to Asterisk Manager from /var/lib/asterisk/bin/retrieve_conf, aborting

Otherwise seems fine. I’ll see if I can migrate my house system over and see how it goes.

Ok we fixed the bug with the manager.conf issue.

Dell PowerEdge 64bit dual processor
FreePBX 2.10.0beta2.5
Asterisk (Ver.

Just installed aastra-scripts
handset logged in and authenticated okay - Still No Service

In the Asterisk Logfiles
[2011-12-01 08:39:46] NOTICE[4795] chan_sip.c: Registration from ‘“Richard” sip:[email protected]:5060’ failed for ‘’ - No matching peer found
[2011-12-01 08:39:46] NOTICE[4795] chan_sip.c: Registration from ‘“Richard” sip:[email protected]:5060’ failed for ‘’ - No matching peer found

Freepbx connections not showing extensions or trunk registrations

FreePBX framework was disabled in Module Admin
Downloaded installed enabled 2.10.0beta2.5
still no calls in or out?

What am I doing wrong?

HP Microserver
FreePBX 64bit Beta

Running into the same issues after multiple installs:

  1. FreePBX Framework & FreePBX ARI Framework are disabled.
  2. Clicking “Submit” after adding a new “Generic SIP Device” goes to a blank HTML
    page unless I update modules in Module Admin.
  3. Once I update modules and am able to add extensions, they don’t show up in FOP.
  4. Adding Conferences, Parking Lots also don’t show in FOP.
  5. Cisco SPA303 phones no longer register, even though they registered without any
    issues on AsteriskNOW and Elastix.

I realize this is a Beta, but if I’m possibly missing anything I’d appreciate any help. I was able to get an AsteriskNOW server going with a very simple dialplan on exactly the same hardware (server & phones).

Guys not sure why it would be having issues. I will try and look at it over Christmas break but last time I checked I could register extensions fine.

I have noticed that when running the 64 bit version of the Distro beta, I am unable to reboot or shutdown the machine from the SysAdmin module. Is this a known problem on the 64 bit beta?

None that I know of but it is Beta so it is possible. Is anyone else having this issue.

Works for me.

I wonder if your incrond demon has crashed. Try doing a /etc/init.d/incrond restart than go back to the module and try a reboot.

Hmm. Tried your sugguestion, but it still doesn’t work for me. FWIW, I believe this was originally installed from the first 64 bit beta release, then was upgraded with the upgrade scripts. Not sure if that could have a bearing on it.

Not sure but it works for me on all 3 versions.

Does it ask you to type in reboot for confirmation?

Yes, it asked me to type reboot for confirmation. In fact, the dialogue box first warns me that it will cause all active calls to drop, then asks me to type reboot, then informs me the system is rebooting to wait at least 5 minutes. But, nothing happens at the machine itself.

Also, I tried Google Chrome, Firefox, and Internet Explorer. Same result with each.

Can anyone else reproduce this as I can not seem to have any issues with it.

Tony - I loaded the new 64 bit iso for in a virtual machine and everything seems to work fine. I loaded all of the same modules to reflect the installed items on my hardware, and I am able to reboot and shutdown the virtual machine from the web browser.

I plan to further tweak the virtual machine to reflect all of the settings I have configured on the hardware install to see if anything breaks it, but for now, perhaps we can assume it was something wacky with my install.

I wonder if you are missing the incrond settings

Can you incrontab -e from linux CLI and tell me what is in that crontab on the machine that is not working.

Running incrontab -e from the linux CLI returns a blank nano screen. No info at all in there.

That is your issue. You are missing the sysadmin RPM. Do a

yum install sysadmin

from the linux CLI

That did it. Thanks for your helpl

Your welcome glad I could help solve someones problem