Freepbx distro 1.814 install error


I am trying to install the latest distro onto a new Hp server (ML110 G7) using the inbuilt RAID on the server. This uses a BD110i controller. I have configured the RAID using the ACU utility supplied by HP but I keep getting the same error.
After the system searches for a DHCP assigned address I get:

Error parsing Kickstart config

The following problem was found on line 7 of the kickstart config:

RAID partition defined without any RAID members

This would suggest that it can see the logical drive but not the physical drives defined within, the trouble is that i’m not entirely sure where to start trouble shooting as the array is configured correctly (according to the array configuration utility).

Any pointers would be greatly appreciated…


I got the same error today on a brand new box, that doesnt have any internal RAID controller. There is an option in the bios to do hardware raid, but I had it set to sas, and even tried IDE. when I had it set to SAS, i’d see sda and sdb, in IDE mode I saw hda and hdb. I went so far as to dd out the disks, but could never get past the ‘RAID partition defined without any RAID members’ error. I was able to do the advanced setup and create the md’s manually.

I had the same error (Same Server HP, ML110G7). I then used Stable-1.812.210.57 ISO version and the installation worked. Then I upgraded to the latest version using the upgrade scripts.

I have been using the distro I downloaded yesterday, which was the latest. In the end I used the advanced installer for CentOS and setup the RAID from their. Just need to test that the RAID works now. A bit frustrated that I couldn’t get the distro to work on the built in RAID, Did you do anythink out of the ordinary esarant?



I got this error with another PC (custom made, not server, 2HDD’s). Stable-1.813.210.58
and Stable-1.814.210.58 won’t install automatically whereas Stable-1.812.210.57 can be installed.By automatically, I mean not interfere with the raid generation at installation.

Draccusfly, I did not do anything out of the ordinary to install Stable-1.812.210.57. I installed is as usuall and then used the upgrade scripts ( to bring it to Stable-1.814.210.58.

Cheers for the reply,

Did you set the RAID up using the ACU software?, with both drives set as RAID 1+0. Also, Did you change anything in the BIOS, ie Enable legacy raid or did you leave that as default?

I will give the 1.812 build a go and see if that changes anything.


With Stable-1.812.210.57 I did not do anything and the installation was perfect. Same exactly setup and 8.13/8.14 were failing(I did not bother to manually fix raid).

Hope this helps

New install started using the 1.812.210.57 build and all went through as expected and installation running as we speak.

Thanks for the advice, I will run the upgrade scripts as soon as it’s finished. BTW have you tested the RAID functionality, ie removed the primary drive, and see if it rebuilds onto t a new disc?


So it sounds like something with Centos 5.8 is different for raid then the 5.7 versions. Is that correct?

I have now successfully installed using the 1.812.210.57-1 Distro, then ran the upgrade scripts so that I am now on 1.814.210.58-2 and it’s working. I have yet to test the RAID functionality (ie fail a drive and see if it rebuilds on the spare) but the Freepbx system admin > storage shows that RAID status is using software Mirror. So all looks good now.


It seems that CentOS 5.8 stuck at the installation, ie the creation of the raid whereas 5.7 does not.

I have not tested raid funtionality yet(fail a drive). I will test it.

I tested drive failure yesterday after running the upgrades to 1.814.210.58-2 distro and in our scenario it worked like a charm. I was able to remove a drive and replace it with another (primary drive removed) and the system booted and worked as though nothing had changed. Although now I have both a green and a red sdb icon (in system admin > storage). Not sure whether the drive should just show green?

But the system still works…


With software raid you hve to mount the drive and rebuild the raid manually.

I published a new 1.814.210.58 ISO and tested it on a hardware system with dual drives and it seems to install and setup the raid now. Can someone who was having issues test a install of this for me also.

that the DB110i card should rebuild the RAID automatically rather than it being done manually (please excuse my ignorance if this ins’t the case, my real world experience of this is limited)

Do you have an instruction set anywhere to manually rebuild the RAID?

I am downloading the 1.814.210.58 from so that I can run a test…