FreePBX / core module 15.0.12.40 is not asterisk 18 ready / line feature broken


(Dirk2358) #1

Hello!

In core/views/trunks/pjsip.php (core module 15.0.12.40), you can find the following line:

$ver_list = array("13.24.0", "16.1.0");

This should be replaced by

$ver_list = array("13.24.0", "16.1.0", "18.0.0");

to get the line feature working again with Asterisk 18.x


(Lorne Gaetz) #2

Already resolved in edge Framework. There is a mechanism in Advanced settings to allow you to manually set the asterisk version to override the detected version, so there is no need to edit code.