FreePBX | Register | Issues | Wiki | Portal | Support

FreePBX calls drop 32 seconds

freepbx
Tags: #<Tag:0x00007fef7bdf7ba0>

(Polezel) #1

I have a FreePBX version 14, the calls from outside to inside fall in 32 seconds, regardless if there is voice or not, I researched it, checked all possibilities plus nothing at all, my FreePBX NAT identifies the external IP normally, the RTP ports 10000-20000, SIP 5060 are open, I put in sip.conf the option canreinvite = no, in advanced settings the NAT = no or yes, I changed the touch times, and nothing changed, in SIP settings the timeout RTP = 30s Hold Timeout = 300 Keep Alive = 0, I made the change of seconds of RTP timeout nothing else has changed.
I use CHAN_PJSIP, the firewall is configured to allow the ip and ports that are used by Freepbx, I tested with the firewall disabled, without any other firewall in the network and also continued in the same way.
I do not use STUN and TURN, they are by default. I debugged the asterisk CLI but I could not see anything that could break my call in those 32s. The PINGS test for specific IPs is not lost at all.
The calls from the inside out do not fall.
FreePBX has two network interfaces one with the internal LAN and the other for authentication with VoIP provider Algar Telecom.
Freepbx is authenticated with the Algar Telecom telephony provider, where I do the configuration on a network interface, the IPs they provide to get to the IP of their SIP server, is working normally.
Is there anything else you can do?
Can it be a problem with the VoIP provider?


(Dave Burgess) #2

You have them open, but are the RTP ports forwarded to the PBX from the firewall?

The logs should tell you exactly why the connection is dropping - what do they say?


(Polezel) #3


(Polezel) #4

I made the nat of the RTP ports in the firewall,


(Preston McNair) #5

In the Asterisk SIP Settings module, detect the external IP in the general tab, and then navigate to the Chan Sip Tab and enter your external IP there, and set it to static. After you do this test a call.


(Polezel) #6

I use CHAN_pjsip and this configuration is already done, and nothing.


#7

Your log doesn’t seem to show the relevant information. (The first and last entries differ by only 19 seconds, so it couldn’t possibly show what went wrong after 32 seconds.)

It would also be useful to have a SIP trace. At the Asterisk command prompt, type
pjsip set logger on
and then make a test incoming call. Answer it and wait for it to drop. The Asterisk log will have the SIP traffic in addition to the normal entries.

Also, please describe your network setup in more detail. Does the second (non-LAN) interface have a public IP address? If not, what does it connect to (an SBC supplied by Algar, a router/firewall to the internet, etc.)? Does the ‘LAN’ interface also have a router connecting to the internet? If so, do both paths have the same public IP address?


(Preston McNair) #8

Yeah, missed the pjsip note in your first post. With your two networks, you will want to make sure that you are using the external IP of the network connected to your sip provider, I’m not really sure which port the autodetection would be using. Also make sure you have an SIP ALG’s turned off on your network (some ISPs will implement those for you on their gear.)


(Polezel) #9

I use two interfaces the first is for internal LAN, only for internal management of the tool, and keep it with internet to be able to perform updates, the second interface and for the connection with SIP server that interface I have set the ip and the gateway that the provider voip provided to get in the IP of the SIP, I made the necessary routes for authentication with provider, it works normal, I do and I get normal calls, but with 32s the call, remembering that the first interface, I make NAT for my public ip, and in that time I do not have firewall on the network, simply so can go eliminating blocking cases and something else, I’m only connected on a router with NAT enabler on the first interface and the second it is connected on the Algar Telecom router voice port.


(Polezel) #10

have a look at my last comment.


#11

Do you have two Local Networks fields in Asterisk SIP Settings? There seems to be a FreePBX bug for pjsip trunks in that regard. See this thread: One way audio .

If that’s your problem, you may be able to use the same fix.

If you still have trouble, capture the SIP on an incoming call. At the Asterisk command prompt, type
pjsip set logger on
and make a failing incoming call. The SIP will appear in the Asterisk log, interspersed with the normal entries. Post the (suitably redacted) section of the log including the incoming INVITE and the 200 OK response.


(Polezel) #12

Solved the problem,
to start the Algar Telecom provider does not need NAT = no, and to solve the problem, when contacting the provider, they verified that my external ip was arriving, which is wrong, I made an interface not a SIP configuration of the Freepbx, for all that exits, leave the voice interface of Algar. UDP = ALL and places the main interface network and the SIP port.


(Polezel) #13

Thank you all for the strength.


(system) #14

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.