FreePBX - Asterisk or Centos closing the connection?

Recently installed the freePBX/AsteriskNow. Nice GUI. I’m using it in a development environment and establishing connections using XLite. The local connection within the LAN have worked great. However, when I’ve attempted to connect using an external address, it worked…but not for very long and eventually fails. Basically, We’ve been able to establish a remote connection to one single extension for about an hour. After an approx hour, the extension is disconnected by AsteriskNow - FreePBX, Centos or otherwise. Any attempts to reconnect fail to permit a connection/answer or otherwise.
Any suggestions would be appreciated.


Are you talking about freepbx or asterisknow? Also this sounds like some kind of port forwarding/NAT issue…

This installation is an AsteriskNow 1.5 with FreePBX. Or is it a FreePBX with Asterisk 1.5. Whichever, It is a Nice looking GUI. The strange thing is it worked for approximately an hour. What type of port/nat setting results in an on-than-off condition like that?

you’d need to describe what the network setup is like (e.g. where the asterisk box is, what kind of router it is behind, what, if anything, is port forwarded, etc…

The remote phone on a Dynamic IP that changes? that will cause a issue…

Have you followed the instructions for creating a remote extension? it is located under documentation, How to’s…

Thanks for the reply.

The router’s configuration

Router Name: WRT54GS with firmware v1.52.5

Host Name: pbx
Domain Name:

Configuration Type
Login Type: Automatic Configuration - DHCP
IP Address: 170.710.18.71
Subnet Mask:
Default Gateway: 170.710.18.1
DNS 1:
DNS 2:

The box is located @ 192.168.702.70

Port Range
Application Start End Protocol IP Address Enable
5038 to 5038 Both to 192.168.702.70 Yes
5060 to 5070 UDP to 192.168.702.70 Yes
10001 to 20000 UDP to 192.168.702.70 Yes
4000 to 5000 Both to 192.168.702.70 Yes

Disable Block Anonymous Internet Requests
Enabled Filter Multicast
Disabled Filter Internet NAT Redirection
Enabled Filter IDENT(Port 113)

Enabled Qos Auto

Thanks for looking into this…

Thanks for the reference. It is an excellent reference. I have used the information and followed the steps. I have edited the sip_nat.conf and adopted the dynamic ip method. To test it, I have the FreePBX successful exposed externally using that domain. Earlier, when the external sip connection was established. With a double ‘hoot’ we could see the Extension ‘light-up’ on the FOP panel. About an hour later, it was offline.
Any suggestions are appreciated.