FreePBX ARI Framework Module Update Problem

Over the weekend, I attempted to update the modules on my FreePBX Distro. Everything succeeded, except for the FreePBX ARI Framework Module. When attempting to update the FreePBX ARI Framework module, I see this message on the Status Popup:

Please wait while module actions are performed

installing files to /var/www/html/recordings..error copying files:
'cp -rf' from src: '/var/www/html/admin/modules/fw_ari/htdocs_ari/*' to dst: '/var/www/html/recordings'...details follow
cp: cannot stat `/var/www/html/admin/modules/fw_ari/htdocs_ari/*': No such file or directory
done, see errors below
installing files to /var/www/html/recordings..done
fw_ari file install done, removing packages from module

The last message shown, ‘fw_ari file install done, removing packages from module’, is as far as it gets. After the update failed, I have attempted to uninstall the module, reboot, and reinstall, but I still get the same result. I cannot complete the update of the FreePBX ARI Framework module.

Has anyone else seen this or a similar problem? Does anyone have any suggestions to get the module update to complete?

Currently I am running:

FreePBX Distro 5.211.65-9

Thank you for any assistance you can provide.

Update to Not sure how you are still on


Thank you for that insanely fast reply! Can’t beat that in any online community!

You were exactly right. Interestingly, the Module Admin page within FreePBX would not offer Since it had downloaded and failed, I had uninstalled the module and tried to reinstall it, which would fail every time. On the Module Admin page, FreePBX ARI Framework was listed as ‘Not Installed (Locally Available)’. Pressing ‘Check Online’ did not offer FreePBX ARI Framework as an updated version of what was already downloaded to my system but not installed.

I resolved the problem by going to the command line and deleting the folder and contents found at: /var/www/html/admin/modules/fw_ari. At that point, I was able to use the ‘Check Online’ button on the Module Admin page, which offered me the FreePBX ARI Framework module. It downloaded and installed without any problems.

Which prompts a question. I can see from the output I posted in my opening post that the module installer was looking for an invalid path, which is why the install was failing. (I didn’t catch that until after I posted.) But, if the system has already downloaded a module and failed to install it, the user has uninstalled it to attempt the install again, should the ‘Check Online’ button prompt the user that an updated version of the module is available online? I’m just curious more than anything. Perhaps the chain of events and timing of my attempt to update were just an unfortunate series of events that led to my issue.

Thanks again for the awesome assistance. I appreciate it very much!

That is not the reason why it was failing. Not even close. It was because a function call was wrong, these types of errors are not something php would display in FreePBX. You probably couldn’t see the new version because you have module admin caching on. Something you can disable in Advanced Settings.

Running these commands would have fixed you up:

amportal a ma delete fw_ari -f
amportal a ma download fw_ari -f
amportal a ma install fw_ari -f

Which is all detailed in this thread (though its super hard to find)