Freepbx and Unifi controller software


(Ralph) #1

I have my pbx working well with all phones and voip connection functioning.
The gateway is a Ubiquiti USG and the whole system is on my LAN network 192.168.1.x
I would like to place the phone system on a subnet VLAN 192.168.105.x
All the system have fixed ip addresses. I started with the pbx changing the ip address via the GUI, this did not work so I did it via CLI.
What happens is that the pbx does not connect to the new address, just hangs and I cannot reach it via SSH or the GUI.
I then connect to the pbx directly and reset the IP address to initial one and all works again. I also tried rebooting but makes no difference.
Am I missing something in the freepbx setup?
I have been able to setup subnets for other devices so I do not think the problem is in the Gateway.

Many thanks


#2

You’re sure that you don’t have a firewall rule on the USG that is blocking inter-vlan routing?

It also sounds like you haven’t actually moved the PBX over to the correct VLAN. If things work again by simply changing the PBX IP back to the initial one, you are missing steps to configure a switch port (or even a LAN port on the USG) to have your voice VLAN (192.168.105.0/24 subnet) untagged on that port.

99.9% this is a VLAN config issue. I would recommend doing some more reading on the differences between VLANs and subnets. Though we typically conflate the two in practice (i.e. 1 subnet per 1 vlan), these are very different things in principle. In other words, a single VLAN can carry multiple subnets, and a single subnet can span multiple VLANs…not to compound any confusion. Subnetting is a layer3 construct and VLANs are a layer2 construct


(Ralph) #3

Thanks vbman123 for your reply. I have suspended all inter vlan firewall rules as a check. I have switch as well and indicated 1 port as the voice vlan. You mention that voice VLAN untagged. The problem with the USG is that if you have multiple vlans i.e. Voice and Data they cannot both be untagged.
I tagged Voice as my choice and this works for phones moving to the VLAN but not freepbx.
Is there a VLAN setting on freepbx I have missed?

Many thanks


(Jared Busch) #4

Why are you adding complication to your network?

There is no point to using a VLAN for VoIP just because.

Is you FreePBX instance a physical machine? The switch port should not be tagged. It should then be untagged on the voice vlan.


(Ralph) #5

freepbx is a physical machine.
I know from previous posts you have made that you see no point in VLAN for freepbx.
I am persuaded of the value from a security point of view.
Tagged or untagged I still am unable to get freepbx to connect to a different network from main LAN.
Phones can be set manually but freepbx seems not to change the ip address even when altered on the GUI Sysadmin.


(Simon Telephonics) #6

“this did not work” - you will have to expand on this a bit.

There is nothing out of the ordinary about having a routed voip network. But you will have to make sure FreePBX understands that the VLAN subnet is “local” so that it does not add NAT handling. You will also have to ensure un-firewalled routing between your VLANs. Start with basic network troubleshooting before investigating FreePBX issues.


(Jared Busch) #7

He wants all of the VoIP stuff on it’s own subnet. So there is no NAT involved.

His problem is that he thinks that he is getting some magic from the “Voice VLAN” button.

Exactly. Because this works every time I have ever used it.
image

Because facts are facts. VLANs have a purpose. None of which apply to voice “just because” voice.


(Simon Telephonics) #8

I guess I would call this question out of scope then. It’s not a FreePBX issue in any way, it’s a network configuration issue that OP should raise with Ubiquiti if unable to resolve.


(John G) #9

As a big user of FreePBX and Ubiquiti (we have 40+ sites in our Controller), I can say that this also isn’t a Ubiquiti issue. If you want your voice stuff on a VLAN for whatever reason, then so be it. It works fine. This is a user configuration problem.

As others have said, you need to better define “this did not work.”

You have a VLAN configured for the FreePBX server – and you’ve set the port that the FreePBX plugs into as being for that VLAN – and you’ve set the IP of the FreePBX statically to an IP on the VLAN – and you say it “doesn’t work”? What do you mean it doesn’t work?

If you change the IP of the FreePBX machine, it will change the IP. I don’t see how that couldn’t work? Or do you just mean that AFTER you change it, you can no longer reach it from the rest of your LAN? Then that is some other configuration issue.

In any case, I agree with isn’t a FreePBX problem. But it isn’t a Ubiquiti “problem” either. But if you need more help, you likely need it more from the Ubiquiti or just VLAN configuration in general side – as opposed to FreePBX…