FreePBX and NCP SIP Trunk (Dial Out to PSTN)


I have figured out how to get FreePBX and a Panasonic NCP1000 to play nice together using a V-SIPGW/16 card. I have used a split extensions numbering scheme to do this.

Extensions on the original system (Panasonic NCP1000) are 1XX, 2XX, 3XX,4XX,5XX and 6XX.
Extensions on the new system (FreePBX running on Hyper-V) are 8XX.

Users on each system can dial each other at will. Two way audio so all good their.

My issues is that the NCP1000 is connected to the PSTN through PRI/32. Users on the NCP1000 can dial 9 to get a idle line and subsequently dial out. What I have not got working is users of the FreePBX system can not dial out. Or at least I do not know how to.

So I am looking for some help with using the SIP trunk to access the PRI lines on the Panasonic NCP1000 from the FreePBX system.

I have tried to add prepend code to the Panasonic outbound routes dial pattern to maybe tell the NCP that we want to access a local idle line and then dial out but that has not worked yet.

Any pointers would be appreciated.

is the tie-line trunk using the from-internal context?

Huh? Context only affects calls into FreePBX from the NCP, but the OP is having trouble with outgoing.

I know nothing about the NCP, but given that this is a FreePBX forum, let’s look at what’s on the wire in case the trouble may be on the FreePBX side.

At the Asterisk command prompt, type
pjsip set logger on
if the trunk is pjsip, or
sip set debug on
if a chan_sip trunk.
Make a failing outbound call, paste the Asterisk log for the call (which will include the SIP trace) at and post the link here.

We can see whether the destination number and caller ID are being sent in the format the NCP expects, as well as what error status the NCP is returning.

If what’s being sent is good but the NCP is rejecting, I found this video about tie trunks, an awful conversion from PPT but better than nothing. It appears that “TIE to CO is restricted by default”. See 10:43 in for details. Also, it appears that the NCP dial plan must accept the destination format; see 10:10 in.

Panasonic for security issues, thus by default trunk to trunk call routing are restricted.
Better to look Panasonic support could help you.

Ok yes I might just be dialing wrong. I do not know if prepending a 9 to the number dialed is the same as dialing 9 on the Panasonic and waiting for a tone and then dialing the rest of the number.

Here is my asterisk -rvvv output with “pjsip set logger on”

WARNING: I did a find and replace on my actual number using a local police number so don’t call it :slight_smile: 2079733700

The last dial pattern I tried on the FreePBX outbound route was (prepend: 9519, prefix: , match XXXXXXXXXX)

So trying to get Panasonic to pick up the line by sending its own PBX code: 951 and then 9 for the line access code. But note even if I remove the 951 from the dial pattern and from the PanasonicPBX I get the same result with gust sending the line access code. Call do get connected but goes to the “PBX operator” extension 203 in our case.

I am told by our Panasonic supplier company that this is because the call is being processed as a DID and because it dose not know where to send 2079733700 it default to the operator extension 203.

I would also include a V-SIPGW/16 protocol trace but it fails to open the window in the KX-NCP Maintenance Console every time. Not sure if its because of a error or if the software is just buggy.

Thank you for your input!


I do not know how trunk to trunk is restricted? What might I need to enable to allow trunk to trunk calling?

I do have the COS set to 1 which I think is the least restricting.

Some settings in my (2.9 System Options) menu are provided below.

Private Network: Public Call through Private Network: Minimum Public Caller ID Digits: 9
Private Network: TIE Call by Extension Numbering (Activation Key Required) : Enable
Transfer: Automatic Answer for Transferred Call: Disable
Automatic Transfer for Extension Call: Disable
Extension/TIE Call: Enable
CLIP Modification (Outgoing): “0” Delete from CLIP: Disable
CLIP Modification (Outgoing): “00” Delete from CLIP: Disable

Hope that helps :slight_smile:

I do not know…

I have not modified the asterisks config files.

I have only been working with the GUI. Except when I wanted to expose the foreign extensions to the IVR menu. I did add a line to extentions.conf

New from-did-direct section is provided below.

; from-did-direct:
; forces ext-findmefollow to take precedence over ext-local. Also exposed to
; the public side to allow an extension number to be used as an external DID
; without requiring inbound routes to be created, common in many PRI installations
where the last 4 digits are used as the extnension and DIDs are delivered in
; 4 digit formats.
include => ext-findmefollow
include => ext-local
; 01052021 IT Support added below line to allow IVR to dial legacy Panasonic
; extensions. By including from-internal context into the from-did-direct context.
include => from-internal

Modifications to extensions.conf only last until the next fwconsole reload. Read the top few lines.

COS (Class of service) control behavior and privileges, thus Extensions and outgoing trunk Calls are controller by COS.

Therefore Extensions and trunk calls control process it can said are controlling by the same rule process.


Extensions/trunk------>External Call Block ------> Toll Restriction Level.


Extensions or trunk COS External Call Block settings are disable call process will stop and send reorder tone.


Extension or trunk COS External Call Block settings is enable call process will be checking by Toll Restriction Level table setting.

Toll Restriction Level can prohibit an extension user or trunk to making certain trunk calls by assign table level from 2 to 6.

Please be advised there isn’t table 1 and 7 because are not programmable.

Need to prepend Panasonic “Idle Line Access (Local Access)” 9 or 0 according to numbering plan configuration to the FreePBX dialed number, otherwise could be one of the reason Panasonic PBX will reject the call process.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.