Freepbx and grandstream hs-ht702 woes

I have Freepbx 2.11.0.11 and a grandstream hs-ht702.

I’ve tried every combination of codecs, to no avail. Initially, I
configured (by accident) the grandstream to connect directly to
flowroute. It worked. Then, I reconfigured the grandstream to
correctly connect to my pbx server. I get a dialtone, and dial, but
get no audio. People can hear me, but I can’t hear anything. I’ve
tried codec by codec, only using one codec on both the pbx and on the
grandstream.

I have in Codecs on the server g723 and lbc enabled, and on the
grandstream g723 & ilbc. In the extension, I have “g723&ilbc” for
Allow.

Here’s one of the most recent logs.

Any suggestions / ideas?

Thanks. (Not sure if more is needed from the logs- numbers munged.)

[2013-11-15 23:21:18] VERBOSE[29893][C-00000031] netsock2.c: == Using
SIP RTP TOS bits 184
[2013-11-15 23:21:18] VERBOSE[29893][C-00000031] netsock2.c: == Using
SIP RTP CoS mark 5
[2013-11-15 23:21:18] VERBOSE[29893][C-00000031] app_dial.c: – Called
SIP/flowroute/###########
[2013-11-15 23:21:18] WARNING[29893][C-00000031] channel.c: No path to
translate from SIP/flowroute-00000032 to SIP/1-00000031
[2013-11-15 23:21:18] VERBOSE[29893][C-00000031] app_macro.c: == Spawn
extension (macro-dialout-trunk, s, 22) exited non-zero on
’SIP/1-00000031’ in macro ‘dialout-trunk’
[2013-11-15 23:21:18] VERBOSE[29893][C-00000031] pbx.c: == Spawn
extension (from-internal, ###########, 5) exited non-zero on
’SIP/1-00000031’
[2013-11-15 23:21:18] VERBOSE[29893][C-00000031] pbx.c: – Executing
[[email protected]:1] Hangup(“SIP/1-00000031”, “”) in new stack
[2013-11-15 23:21:18] VERBOSE[29893][C-00000031] pbx.c: == Spawn
extension (from-internal, h, 1) exited non-zero on ‘SIP/1-00000031’

Thanks.

You will have to use a codec supported by your vsp, probably neither g723 nor lbc, start with g711 ( a or mu as appropriate) , that is almost always supported. Make sure any license encumbered codecs arte so licensed before attempting to use them .

Pardon my ignorance… What’s VSP?

I tried every mutual codec that I see on both the grandstream and freepbx. I don’t see g711 on either the grandstream or the freepbx?

Thanks :slight_smile:

VSP - Voice service provider. g.711 ITU protocol number for alaw or ulaw linear coding.

alaw is outside us
ulaw is US and most of north america

In re-reading your post I don’t think the you have a CODEC problem. The call would not complete if you didn’t have a valid CODEC.

You say you have no audio. Is the phone and the server in the same network?

VSP - is that then flowroute?

The server is a dedicated hosted server, public IP. the phone is behind a NAT gateway at my house. But as I mentiioned, when I set the ATA to use the flowroute directly (incorrectly), it worked. But when it’s using my pbx, I either get no audio inbound (people can hear me), or I get a fast busy BUT the call is made.

Sounds like you have network issues with your hosted server. Make sure all NAT settings are correct in sip settings module.

I had it set to:
NAT: No
IP: Static
IP: #.#.#.# (My IP).

Should it be set to public since it’s a public IP? I’ll try that now.

No go with being set as a public IP with the correct details.

Any other suggestions? If there were a way to dump my config from Freepbx and the grandstream, I’d love to. Now, I’ve actually heard one ring when calling from the phone, but that’s it.

A friend of myne suggested I need to set TCP somewhere since my grandstream is behind a NAT. Only places I see is under Extension: Transport: TCP Only. Not sure what else to check. :frowning:

You need to turn on any NAT settings ON THE PHONE. What kind of router do you have? Basically, if you don’t port forward on the home router (I don’t recommend that) you need to make the phone connect to the remote PBX, and then keep a session open.

On Snom phones I enabled “Keepalive interval” to be at 120 seconds. This means it sends out a UDP packect at that interval to keep the session open so that audio can come back in and not get blocked. You also might look at any Symmetrical RTP settings you have. I don’t have that set but it might help you.

This is a standard POTS phone plugged into a grandstream adapter.

Like I said, worked fine when connecting directly to the florwoute server (ie in Grandstream setup, server - sip.flowroute.com). So it’s gotta be something on my pbx, right? I’ll look at the keep alive, I think it’s now set to 90?

Okay, then the settings on the adapter should have some sort of NAT helping. Any keepalive under 180 will be fine, so 90 should work. Take a look at your firewall and make sure you’re keeping connections active.

However, the PBX has to play smart too. There are several NAT settings in the GUI. Application / Extension itself has one, Settings / Asterisk SIP Settings is another.

Hi,

Thanks for the reply. In Freepbx, Applications / Extensions, I see NAT: and either Yes or route - nat no rport. With route - nat no rport, same issue. With yes, the ringing I hear when calling is like a warped ring. The person calling me hears like major echo of themselves.

In SIP Settings, I see NAT: (I assumed this was if the pbx was on a nat…Tried yes and noroute.

reinvite behavior, think I tried each setting too.

You have not stated what kind of a router/firewall is in use at the home site. There may be an issue there. Get one that will show you active connections.

Anyone willing to take a look for a reasonable fee - right now not sure what I changed but now not even software softphones work (which did before). If I can verify you’re a reputable person / business, I’m OK giving access to the box and the grandstream. I don’t forsee this taking more than like 30 minutes really (I’m sure if you’ve configured a few of these boxes, it won’t take much more than that to run through the screens and go “Ohhhh you unchecked this box by accident!” and see the mistake or option that’s wrong. But as it is, I’ve spent nearly 2 weeks on this, and obviously paying the hosting / VPS fee, so it’s worth it to spend a reasonable fee to have a ‘expert’ take a look…

Thanks.

It has been in front of your nose for those two weeks.

Sorry, never saw that link. $150 is a little pricy IMHO for likely 30 minutes. But I think I’ve narrowed it down to being a local network issue - but hopefully someone here can share some insight. At home, I have a comcast modem in Bridged mode to a Linksys Wired / wireless router. I’ve configured the grandstream as a DMZ. No go. I downloaded Zoiper on my Android device, on WiFi (haven’t yet set that as DMZ, but as is, no go). Tried Zoiper on Android at work network (also behind a NAT gateway I have no control over) and it works fine. So something on my home router appears to be - ahem… misconfigured? I’m not sure what to look for… It’s a Linksys router running DD-WRT.

Thanks.