FreePBX and call recording in .gsm format

Is there a way to force freepbx to record call conversations in .gsm format?

my voicemails are doing so, which is great.

I don’t really want to have to run a SOX script every 15 minutes to convert the calls, but rather have them compiled as .gsm to start with.

Any ideas guys?

That works fine, thanks! [Don’t use the record on demand feature, I’ll let someone else test that.]

Is extensions.conf going to be overwritten when I make a change, so I’ll have to remember to redo this?


Is extensions.conf going to be overwritten when I make a change, so I’ll have to remember to redo this?


I made some modifications to the code as following:

File extension.conf
=> …alter value in variable mixmonitor(&{callfilename}.gsm)
=> …in context[macro-record-enable] add line : exten => s,n,SET(touch_monitor_format = gsm:monitor) This make it recordings in gsm after press *1 (on demand)

Try this and let me know if works for you…


Complementation off message above…
Just to correct the lines of code. Sorry for my case issues failure:
exten => s,n,Set(TOUCH_MONITOR_FORMAT=gsm:monitor)


; 1st listed format gets emailed

Isn’t that for voicemail, my voicemail is fine it’s recording as .gsm.

I want the stuff thats done by monitor…

/var/spool/asterisk/monitor/ to be in .gsm format by default, not .wav.

Is this a freePBX setting? Asterisk setting?

I found a setting in /etc/asterisk/agents.conf but it doesn’t have any effect.

Any other hints?


I am also trying to do this and I wonder if the release of FreePBX 2.4 alters this solution in any way.
Secondly I just want to clear up the solution as I am a little confused. If I understand the above instructions correctly I need to rewrite the following line in extensions.conf to read like:


and then add this next line under the one above.

exten => s,n,Set(TOUCH_MONITOR_FORMAT=gsm:monitor)

Does this change the recording format to GSM for both on demand and reocord always?

Is there any way to have these recordings e-mailed and treated similar to a voicemail?

Lastly, is there a better place to put these lines then in the extensions.conf file?

I tried this fix and now I cannot listen to recorded messages using the voicemail and recordings website provided by Trix. It looks like I need to either use .wav files which are huge or come uw with a different way to listen to my recorded messages.

Hi All,

I found this thread while searching and I think this is where to add my post. I am having strange issues with my recordings with MixMonitor. Recording sometimes don’t align (i.e Recorded conversations of Customers and Agents (connected with a queue) does not follow smoothly on the same recorded file.

e.g Agent says “Hello” before customer say “Hi”, Agent would have said “How are you”, and son on like that. But all conversation recorded in the same file, but get mixed up. A times, the recording might be that, agent talking and customer talking at the same time on the same recorded file.

I use Asterisk-1.18.0 and FreePBX-2.4.0. Any help with this issue pls.

Cheers to all.


Please post this as a new question. It’s not directly relaited (question is about recording format) and even if it was it’s really a old post and will probably get missed.

Most people scan new messages for topics that they can answer or are interested in and your questions topic will not show up as it’s under the initial posters topic.