FreePBX and Anveo Direct (outbound)

I am trying to be able to use Anveo Direct for outbound calls, but I am unable to for over a week now. The inbound calls I receive work as expected but not the outbound ones. If there is anyone that can help me make it work, I would appreciate it.

I only have one PJSIP account, and I just need to be able to make calls through it with my SIP client.

Some things that might help anyone who is willing to guide me are:

  • I have my PBX’s IP addresses in the Anveo whitelist.
  • I do not use any security prefixes so far, since they are optional.
  • My SIP client is successfully registering with FreePBX account 31338 (screenshots of the account below).
  • I have created a Trunk pointing to Anveo (screenshots below).
  • I have created an Outgoing Route (screenshots below).

What is happening:
When I try to make a call, I get the following NOTICE in my Asterisk CLI (Where “3069XXXXXXXX” is the number I try to call through Anveo Direct).

[2023-04-12 10:40:48] NOTICE[12257]: res_pjsip_session.c:3985 new_invite: 31338: Call (UDP: to extension '3069XXXXXXXX' rejected because extension not found in context 'from-trunk'.

Local extensions must be in the context from-internal, you have yours set to from-trunk.

Tried with the correct context just now. I still get…

[2023-04-12 12:13:04] NOTICE[12257]: res_pjsip_session.c:3985 new_invite: 31338: Call (UDP: to extension '3069XXXXXXXX' rejected because extension not found in context 'from-internal'.

There’s something wrong with the outbound route, but I can’t tell what from the screen cap.

Is there a way that I could somehow give access to you or anyone else access to the dashboard via AnyDesk or something, and pay for the fix? :confused:

I’m a little bit disappointed. Too much time for something “simple”…

Do not allow any random person to just connect to your equipment. That seems like you are asking for trouble.

Can you post a screenshot with your dial patterns on the outbound route?

Hello, thank you for spending time on this. I deleted the outbound route and the until-now extensions and tried to find the root of the problem by creating two internal extensions and test if one can call the other and vice versa. It seems that even with the local extensions the problem remains. I get the exact same error. Even if I try to do an echo test, I get a “not found” error on my sip client, and the same “reject” notice in the asterisk cli logs.

Both extensions I have now are just simple extensions to which I can register with my sip clients successfully. Both seem to be reachable in the CLI. But anything I do, I get the same error.

I have googled so much that I think my head will explode.

I even tried to enable both legacy sip and pjsip in a try to find what causes that error, but still no luck.

That’s why I am asking for remote assistance through my computer… :confused:

It is the most simple thing what I am trying to do, but no, not even echo test is doable.

My extensions.conf under from-internal has the following, if that helps.

include => from-internal-noxfer
include => from-internal-xfer
include => bad-number ; auto-generated
exten => h,1,Macro(hangupcall)

Post the output of pjsip show contacts in the asterisk console If they are PJSIP extensions as well as the full output of a failed call from the full logs with pjsip set logger on.

Have you edited any files manually, or are you working entirely within the GUI?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.