FreePBX 6.12.65 Installation Incomplete

I can’t find anything in here related to this, but that could be because of how I am searching for it.

I really don’t know how to describe this because I have installed FreePBX serveral times without any issues.

On the FreePBX 6.12.65 ISO, the installation at one point asks what type of installation it is (Basic Server, Desktop, Minimal…). I find that odd because I don’t remember those choices being there for the FreePBX ISO install.

I have tried Basic Server and Minimal a couple times and even burned a new ISO.

Every time I install, I can’t use yum to update anything because there is no repolist for yum:

[[email protected] ~]# yum repolist
Loaded plugins: fastestmirror
repolist: 0
[[email protected] ~]#

There is a /usr/src/freepbx-12.0.45 directory, but unlike a typical installation, nothing seems to have installed.

Apache isn’t running and the hosts file needs to be edited for it to start up.

Iptables has to be edited to allow port 80 and then when apache does start, I get the generic Apache start page.

The installation process from the FreePBX Distro has changed dramatically from the instructions and I must be doing something wrong when installing it, but I can’t seem to see what that is.

If anyone has any input or suggestions, I would appreciate it.

Thank you.

Do you have valid internet?

Yup. The first time I installed it I didn’t and thought that was the problem. The subsequent tries I made sure to configure the network and DNS.

When I configured everything in the startup process, I still had to manually add the nameserver entry in /etc/resolv.conf but upon doing that I can ping google.com and anywhere on the outside network.

download a new iso i just did a new install and i didnt see any of them choices either

Some more information. I took the same ISO and installed it on a VM. I got the green text menu as depicted in the installation instructions that I have always gotten.

For some reason when I install this on the Dell PowerEdge R320, I get a graphical installation menu that is a closer representation to a CentOS install.

Still trying to figure out why I get a graphical install in the PowerEdge but the normal text install in the VM.

@jerlasvegas, Can you confirm the ISO was downloaded from www.schmoozecom.com/distro-download.php and have you checked it against the checksums we publish? The reason I ask is because the yum repo is one of the last things done as part of the of the base installation (prior to our first boot).

Your server is doing something to ignore our install screen.

The ISO was downloaded from www.schmoozecom.com/distro-download.php and I have confirmed the MD5 checksum. It is a match.

So I tested a second PowerEdge R320 and it does the same thing. Instead of booting into a text installation with the green menu, it boots into a graphical installation and gives me a choice of packages I want to install. PBX is selected, but none of the packages within the group are selected.

I used the same exact ISO in a Virtual Machine and it boots into the text installation.

I would agree that my server is doing something strange when booting up. Just have to figure out what and why.

Do you have any insight on a Schmooze Graphical Install that gives you a choice of packages opposed to the green grub menu that is typically displayed?

So when I boot the ISO in a VM, this is the Grub screen that comes up

When I boot the IOS in the Dell Server, I have 3 seconds to view the boot menu and this comes up if I hit a key

Same ISO, except in the VM, it appears that I am indeed installing the FreePBX Distro whereas with the Dell server, it looks like I am installing a Schmooze branded Linux.

If I select PBX 6.5 or Install system with basic video driver, I then get this screen:

In the BIOS, I changed the boot setting from UEFI to BIOS. This resolved the issue.

I am ran in to the same issue installing on a Dell R730. Thank you the change worked fine.