FreePBX 40 and CallCentric with Asterisk ver: 18.13.0 and FreePBX ver with pjsip


Following from this previous post I managed to get a new install completed on the box.

With the new install I now have pjsip as the option and I’m struggling a bit to get connected to Callcentric. I actually got the box connected to callcentric and a phone connected to the PBX, but I’m not able to get an outbound and inbound call.

I have my provided 1777XXX number from Callcentric, but also a temporary DID which is in place until I port our office number over.

It doesn’t seem the Callcentric guides are updated with the latest FreePBX. They provide some entries for the conf files, but when I apply those, and update with my settings, Asterisk doesn’t want to run.

It seems I am missing a key piece to get a call to flow in and out of the system, curious if there are any suggestions on what to check.

Kind regards,

Can’t seem to reply to any post… so limiting…

Ugh… “We appreciate your enthusiasm, keep it up! That said, for the safety of our community, you’ve reached the maximum number of replies a new user can create on their first day. Please wait 14 hours and you’ll be able to create more replies.”

Thank you, sir! It was a bit frustrating at first.

The best thing I have to go off of from Callcentric is this:

but they seem to assume you’d edit the files. I think this is just with Asterisk. I’ve managed to piece out of this what I need to plug into the GUI, but I think I’m missing something that bridges inbound and outbound calls together and I just can’t seem to find those missing pieces.

Thanks for following up :slight_smile:

If you are placing directly into Asterisk Conf files, FreePBX will overwrite them. The config needs to done through the GUI.

Is it using authentication or are the just pointing to your IP?

Glad you got the new install running!

1 Like

Here are my pjsip trunk settings for Callcentric. Everything not mentioned should be left at default. Replace 1777xxxxxxx with your Callcentric 1777 number.
Trunk Name: (as desired)
Outbound CallerID: 1777xxxxxxx (or a DID you have with Callcentric)
Username: 1777xxxxxxx
Secret: (your SIP password set at Callcentric)
SIP Server:
Contact User: 1777xxxxxxx
From Domain:
From User: 1777xxxxxxx
Match (Permit):,
Send RPID/PAI: Both

Outbound Route should send 11-digit domestic numbers to CC. If your system allows other dialing formats, they should be converted to 11-digit format. 911 should be sent unmodified. You may need other entries for international, voicemail, special features, etc.

Inbound Route can use the 1777 number as DID Number, or see

Hi Richard, Authentication is in use.

Appreciate the details, Stewart. I’ve compared and it seems my settings align. I suspect I’m missing something somewhere.

If I dial in, it rings once and disconnects. Outbound calls throw error saying call can’t be completed.

I’ve got a ticket in with CallCentric as well.

Apologies for the delayed reply, as a new user they lock the number of replies I can submit in a time period. Makes for a challenging way to engage with people trying to help.


Outbound calls: It appears that the Outbound Route is not being matched. Temporarily change it to
Prepend: (leave blank)
Prefix: (leave blank)
Match pattern: X.
Then call (for example) 18004377950 to test. If no luck, at the Asterisk command prompt type
pjsip set logger on
make a failing call, paste the Asterisk log for the call at and post the link here.

Inbound calls: If anything appears in the Asterisk log for an attempted call, paste the log (including pjsip logger) as above. If nothing logged, is your trunk registered? If not, paste the log for a register attempt. If yes, post details about router/firewall, ISP, etc.

Hi Stewart,

Appreciate the help. As requested:

pjsip log for outbound call attempt: 20220904-1453-pjsip-log - FreePBX Pastebin

asterisk full log for inbound call attempt: 20220904-1501-asterisk-full-log-inbound-call-attem - FreePBX Pastebin

callcentric shows I’m registered to the default extension.

If I missed something you still need let me know. If there’s interest in connecting and checking, I can help set that up as well.

Be well!

INVITE sip:[email protected]:5060 SIP/2.0
It appears that the Yealink put an additional 1 in front of the number. In the phone, go to Settings → Dial Plan and clear out any Replace Rules.

Inbound shows no call. Check settings at CC.

Hi Stewart,

That 11800 was actually a mistake on my part. Further in the log you should see it dialing correctly. I cleaned up the log and made a new pastebin.

Also working with callcentric on the inbound and waiting for some updates from them.

If I’m wrong on my assessment of the 800 number let me know.


There is still no match for the Outbound Route. For testing, just make an entry with match pattern ‘X.’ (without the quotes) and with prepend and prefix left blank. Enter the CC trunk in the trunk list.

Got a reply from CallCentric stating:

"What appears to be occurring is that the call is being made internally, instead of being sent to your Callcentric trunk. To confirm, are you adding “9” as the prefix in your Outbound call attempts as defined within your Asterisk’s dial plan? "

I didn’t realize that required a 9. Upon dialing 9 - and then the number, all was good.

I assume I should be able to plug the 9 into the dial pattern in the prepend box? If yes, I’ve tried that but it fails. I’m doing some more reading on where this goes in FreePBX.


Hello again!

I have outbound calls working just fine from my single phone here. Will need to test with multiple phones once I have the chance.

As for inbound, I’m a bit sheepish to say that I still had call treatments and IVR enabled on the callCentric side (facepalm). Per CallCentric, I’ve disabled all of those, and with a couple of other pjsip setting changes, I now have inbound calls working as well.

Thank you Stewart and Richard for the really great, and timely feedback, I really appreciate it!

I’ll post some updates as I finish getting it setup and then migrated.

Be well!

1 Like

I had asked for the config, but I saw that I missed setting RPID to both after re-reading this. Thanks for posting this!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.