FreePBX Reload times out

We are running FreePBX with custom contexts on the new distro. Everything works great except that after we loaded an outbound route with 5,000 dial patterns the PBX reload times out. We click on “apply configuration changes” and the screen hangs at “please wait reloading” forever.

When I look at the asterisk CLI during an SSH session I can see the reload complete but the GUI hangs at the reload screen until I press F5 to reload the page.

We had a similar issue in FreePBX 2.8 where any reload resulted in a GUI error mssg “Error: Did not receive valid response from server” and I was under the impression that this was resolved in V2.9

Please do not reply that I should not have that many dial patters because clearly I do need them if I have them and other than this GUI issue it does not cause any problems on our system. With US NPA/NXX rate tables you sometimes must enter thousands of dial patterns if you want to use the best LCR route.

How many devices/users/extensions are loaded in the freepbx?

I’d be looking at the php.ini

max_execution_time = 30 ; Maximum execution time of each script, in seconds max_input_time = 60 ; Maximum amount of time each script may spend parsing request data

Maybe tune that to suit the amount of time it’s taking.

I tried changing the various limits in php.ini but unfortunately nothing helps. I even tried some crazy values in the hope that I would hit the right number but nothing. The only thing I noticed is that it happens always in Firefox but never in Chrome.

Maximum execution time = 180
Maximum input parsing time = 90
Maximum memory allocation = 256