FreePBX 2.11 to 15 restoration failure


#1

Hello all,
I am working on upgrading a pbx system that is version 2.11 to version 15. I have created the full backup on the version 2 system. When I attempt to restore from the backup on the v15 system, it gets stuck at 99.99% or 100%. I have uploaded the backup to /var/spool/asterisk/backup/uploads with sftp and gave asterisk ownership. When I run the fwconsole backup --restore command, I get the following error.
image
I was told by a colleague that this was an error on the backup, but I have tried this with multiple backups and still get the same error. Any help on working around this would be greatly appreciated.


#2

compare the md5sum of the .tgz file generated on the donor machine with the one on the recipient machine after the ‘upload’


#3

Thanks for your reply dicko. It looks like it matches.

image

image


#4

Then the upload was fine but the tgz file is broke. Can you successfully restore it on your 2.11 machine?


#5

I am not sure, I have not tried that. The 2.11 machine is currently in production and I would be scared to take it down if the restore did not bring everything back for some reason. I can possibly test this later in the day.


#6

You can restore ‘piecemeal’ in the GUI, try restoring bit by bit in the recipient machine (restore the cdr’s last)


#7

How do I select what I am restoring in the gui? The guide that I have used on how to create a full system backup says to drag these for templates into the backup items:
cdr’s
full backup
system audio
voice mail

So would I do a backup for each template and then restore each of those one at a time?


#8

Iterate one by one though

cdr’s
full backup
system audio
voice mail

start with full backup, the other three can be rsynced/mysqldumped if problematic


#9

copy that, I’ll try this method and let you know how it goes


#10

It seems like this is working, I’m gonna test later today but it looks good so far, thank you Dicko