Freepbx 2.10 during System Recording upload /var/spool/asterisk/tmp/unnumbered-ivrrecording.wav not created

After more trouble shooting on my own, see my next comment on what happens when trying to upload via system recordings.
The name your upload part of the page will work if the /var/spool/asterisk/tmp/unnumbered-ivrrecording.wav is present in that directory. Why is it not being created during the upload? See my comment below for more.

Asterisk 1.8 with all the updates,
Freepbx 2.10 with all the updates.

After a security update for Apache, I cannot upload files
via the System Recordings page. (I have been uploading files for months
without any problems.) I have IE8, IE 9, Firefox 11, Chrome 18.0 all the same.
A remoter user with IE8 was able to upload via the System Recordings page.
I tried two computers at my location, same result.

Here is what happens:

I select the wave file to be uploaded,
(I have tried several, even old ones renamed that previously worked)
Click the upload button,
Click the wait for reload,
Wait, and then nothing happens.
The file name disappears from the selection area.
I started the debugging/logging and here is the result:

2012-Apr-02 14:44:16 /var/www/html/admin/modules/recordings/page.recordings.php:191
[NOTICE]: Undefined variable: tabindex

2012-Apr-02 14:44:16 /var/www/html/admin/modules/recordings/page.recordings.php:234
[NOTICE]: Undefined variable: rname

2012-Apr-02 14:44:16 /var/www/html/admin/modules/recordings/page.recordings.php:240
[NOTICE]: Undefined variable: suffix

The above was the result with IE8, IE9, Chrome and Firefox, all the same.

Thanks for your help.

/var/spool/asterisk/tmp/unnumbered-ivrrecording.wav is the name of the file that the system recordings upload makes when you hit the upload button.

For some reason this file is not being made. Something is not allowing a wav file to be uploaded and given this name. If you place a file in that directory and rename it, you can use the save file naming function and it will name and register the file with freepbx and asterisk.

What is stopping the file from being uploaded? And what do we do to fix this?

footnote: a file that was a gsm file was uploaded by mistake! and it worked!
Maybe a clue to what is broken.