Freepbx 17 problems feedback

I just did the following:

  1. installed the latest Debian (Bookworm) 12.5 using the complete install in VirtualBox
  2. Tried to run the install script commands as found here

First problem: Script failed to run because it was looking at the “DVD” ISO as the apt source. I fixed it by doing this.

  1. I ran the script again and it worked.
  2. I logged into the web UI from another computer, and it wanted me to turn on the firewall.

Second problem: I clicked “yes” on each question, but I was suddenly locked out before even being able to finish the firewall setup. I had certainly whitelisted my own computer already. I’ve run into this on FreePBX 16, too though. If you take too long going through the firewall setup wizard, you can’t finish the process.

  1. So I rebooted the VM and tried the firewall wizard again, clicking yes, quickly. I made it further, but still got locked out.
  2. I then attempted to disable the firewall using “fwconsole ma delete firewall”

Third problem: bash: fwconsole: command not found

  1. I gave up on testing FreePBX 17
which fwconsole

should return

/sbin/fwconsole

You should run

echo $PATH

to make sure that you have /sbin included

I can’t speak to your first issues relating to your VirtualBox installation.

Yeah, I’m not sure why the default after installing Debian was to use the ISO as the APT source. I just thought I’d mention it since this is the first time the default Freepbx install is not a full ISO itself, so there are likely to be questions on what the “best” way to install Debian is for those who want to install FreePBX next.

I’m not able to look into it at the moment, but I would be shocked if “which fwconsole” returned anything, since fwconsole wasn’t found in the first place.

Regardless, this is something that I would expect the script to take care of. I could have continued working and fixed that problem, but I’m simply trying to help out by reporting back that a simple install doesn’t work as I expected it to. I’m happy to provide more details if it would be a help to the devs.

I suspect it had something to do with your Debian instance and the way it was installed. I haven’t seen any issues raised with FreePBX relating to your issues, though you certainly could - Issues · FreePBX/issue-tracker (github.com)

I just installed Freepbx 17 Beta on Debian 12 only had one small issue with the install script but I took care of it by installing these 2 things as per errors in the Logs:
fwconsole ma install vqplus
fwconsole ma enable vqplus

Script worked perfectly after that, and my install works perfectly. As for the Debian CD/DVD repo, Debian does this by default from a Vannilla Install of Debian 12 from DVD One can just comment it out and use online repos.

@adell4444 Do you know if I keep updating this instance, can I just keep it and update it until FreePBX is stable and ready for production? Do you know if this version can be used for that?

One last question does anyone know how far the Commercial modules are away from being ported to Debian? My most important one needed is FaxPRO.

In the past, I don’t think you could update from beta straight to a stable release. With the Debian version I’m not entirely sure how it will work. I’m also not sure how far along they are with porting the commercial modules - @lgaetz any insight on either of these questions?

Darn. I guess we’ll see what @lgaetz says about the Debian Version. No big deal either way, I can just re-install the stable version of FreePBX 17 on Debian when it is released if I need to.

Just out of Curiosity, are you running a FreePBX17 BETA on Debian 12 box? On FreePBX 14, 15 and 16 I used a small script to keep CentOS and FreePBX up to date (A member here had a good script and it NEVER failed me). I Never had an issue with it, but I just did basic OS updates and then Module updates. My question would be now that we are on Debian 12 with FreePBX17 BETA, is it, “Safe” for me to do Standard Debian Updates, and as long as I am NOT upgrading to a new Debian version, is there any fear of Debian 12 getting too far ahead of FreePBX 17, or as long as I do FreePBX module updates alongside my Current Version OS updates, should I be good? My goal in testing the beta is to keep the system and modules as update to date as possible, to see if anything breaks and how often.

So instead of yum you are using apt.

apt update && apt upgrade -y

The FreePBX module upgrade process remains the same

fwconsole ma updateall

Yes, that is exactly what I am doing ha ha ha. Perfect.

Hi @jtbayly just fyi - Latest install script got the fix to handle the DVD ISO as well. Ref - [improvement]: installation Script fails when CDROM repo added. · Issue #182 · FreePBX/issue-tracker · GitHub Thanks

2 Likes

That’s great, @kgupta. Any idea about what the problem could have been on this other issue?

I wouldn’t expect the script to succeed without fwconsole being both available and added to my PATH.

Thanks.

not sure why “fwconsole” not present in your system. I suggest please raise issue at github and share your “echo $PATH” output so we can continue the discussion in the github to debug your issue. thanks.

1 Like

Finally got a chance to do this. Here are the results:

/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games

So your PATH doesn’t contain /sbin which is where fwconsole is located. You can either run the command specifying the path (e.g. /sbin/fwconsole reload) or add it to your path.

PATH=/sbin:$PATH

Whether or not this is a version 17 bug I don’t know. This hasn’t happened to me on my installations. @kgupta may be a better judge of this.

It has not happened to me either on my test installs.

Yeah, it’s very odd. I would expect sbin to be part of the PATH as a default part of the OS install.

You could always fire up and new test FreePBX 17 install and see if you can reproduce the issue. Plus, the script has been updated, so it would be good to know.

sbin traditionally contains ‘System BINaries’ by inference that would need root privilege and there is a lot of stuff in that directory you REALLY don’t want to give a PBX access to, probably wait for Sangoma to ‘elevate’ that privilege/path to the ‘asterisk user’ as they are still learning debian, hopefully they will do with sudo not a cavalier PATH addition.