FreePBX 17 dahdi missing drivers?

I installed the freepbx 17 update using the --dahdi-only to install the dahdi system since I didn’t install it originally. I have a T100P single-port T1 card and it uses the wct1xxp driver which worked in Centos and FreePBX 16. It appears wct1xxp driver is not installed becuase while I get the following line when I run dahdi_hardware:

pci:0000:04:00.0 wct1xxp- e159:0001 Digium Wildcard T100P T1/PRI or E100P E1/PRA Board

I only have the following drivers:

root@phones:/lib/modules/6.1.0-21-amd64/extra/dahdi# ls
dahdi_dynamic_eth.ko    dahdi_dynamic_loc.ko   dahdi_echocan_mg2.ko    dahdi_echocan_sec.ko  Module.symvers  wcaxx.ko  wctc4xxp     wcte43x.ko
dahdi_dynamic_ethmf.ko  dahdi_echocan_jpah.ko  dahdi_echocan_oslec.ko  dahdi.ko              oct612x         wcb4xxp   wctdm24xxp   xpp
dahdi_dynamic.ko        dahdi_echocan_kb1.ko   dahdi_echocan_sec2.ko   dahdi_transcode.ko    voicebus        wct4xxp   wcte13xp.ko

Am I missing the driver or am I doing something wrong? In my case - either option is likely!

Hi @rickthegeek Raised [bug]: freepbx-17-dahdi-missing-drivers · Issue #206 · FreePBX/issue-tracker · GitHub to keep track of this issue. We are looking into this one. Thanks

Hi @rickthegeek

We have published new RPMs with wct1xxp driver so please update your system and give a try. If yuo face any issue please raise the jira. thanks.

apt update
apt upgrade

Seeing the driver and its loaded fine! Thanks!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.