FreePBX 16: FastAGI does not start at boot


I realized that when my FreePBX server boots (a SBC, a Nanopi Neo3), the FastAGI server doesn’t. So, incoming calls cannot go through the IVR.

With fwconsole restart I get:

Running FreePBX shutdown…

Running Asterisk pre from Core module
Stopping Call Transfer Monitoring Service
Core FastAGI Server is not running
Shutting down Asterisk Gracefully. Will forcefully kill after 30 seconds.
Press C to Cancel
Press N to shut down NOW
[============================] < 1 sec
Running FreePBX startup…
Starting Asterisk…
[============================] 15 secs
Asterisk Started
Running Asterisk post from Core module
Starting Call Transfer Monitoring Service
Stopping Call Transfer Monitoring Service
Restarting Call Transfer Monitoring Service
Starting Core FastAGI Server…
[>---------------------------] 11 secs
Started Core FastAGI Server. PID is 3040

then FreePBX runs normally.

How can I figure out why FastAGI isn’t starting at boot?


Not a fix, but a workaround. You can disable fastagi in Advanced Settings. On a system with low call volume, the difference would not be noticed.

1 Like

Thank you, my system is exactly like that. I use it at home to filter robocalls.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.