Freepbx 15 Ring Groups & Missed Calls


(Bifur) #1

Still having an issue with missed calls not working as they are suppose to. For reference please see the same issue here:


and
https://issues.freepbx.org/browse/FREEPBX-19795

To summarize the issue: Basically, missed calls are being left on all endpoints in a ring group who did not answer (call was answered by one endpoint and should not show up as missed on the other endpoints).

On my PBXs with version 14 still I am able to downgrade Ring Groups to version 14.0.1.11 and that resolved the issue. On a 15 box I am not able to downgrade to this version (obviously) and tried multiple different versions with the same issue.

Has anyone found a workaround? The bug tracker says the issue has been resolved but people are stating it is still an issue so I am sure it is affecting more users.

Thanks!

PS I am currently fully upgraded on Freepbx 15


#2

You can do a test on a virtual machine with FreePBX 15 installed, then download & force install the version 14.0.1.11 ring group module, then do a test. You would have to make sure version 15 is not installed. I think it should function. You could even try to do it on the production one after hours. Just make sure you do a backup.

Seems a new ticket has been opened.

https://issues.freepbx.org/browse/FREEPBX-21311

Took them a year to “fix” the last one.


(Bifur) #3

I guess I will have to try that. It’s a shame. I just moved this client to 15 from an old old Freepbx version (2012ish) which worked fine for them but they wanted to start using soft phone apps on their cell phone. PJSIP seems to handle this a lot better and I like them being able to have multiple registrations/contacts. Now something as simple as ring groups is causing issues!


#4

Should be able to find the old version here


(Kapil Gupta) #5

Hi All

https://issues.freepbx.org/browse/FREEPBX-21311 issue has been resolved and couple of our community friends also confirmed that its working fine for there respective phones brands/models.

Fix is available in edge release of ringgroups module to give try.

ringgroups v14.0.1.14
ringgroups v15.0.11.8

Best Regards
Kapil


(Bifur) #6

I upgraded to 15.0.11.8. I applied changes, tested, and the issue seems to persist. We are using 2 Cisco 508G phones. I selected Mark calls as Answered to yes and no, and there was no difference. When one phone answered, the other phone showed a missed call.

I tried fwconsole restart and rebooted the server as well.

@GeekBoy were you able to test this? I was about to try your suggestion and downgrade to the 14 version, but then I saw the reply that this was fixed so tried this first.


#7

I keep most PBXs on virtual machines so I am able to regress a bit. I was not able to test if putting the old version 14 of the ringgroups on FreePBX 15 will work, but it should. In the past, I have seen previous versions of modules on current FreePBX versions after an upgrade.

Just remove the ringgroup version 15.x and grab the version 14.0.1.11 off github to install.


(Bifur) #8

I meant were you able to try the latest edge ring group to see if it fixes the overall issue?

I am going to try the version 14 one here in a few. I just created a new VM for another client this week and will test it first.


#9

I don’t really have any FreePBX 15 up now so no I am unable to check. I see they claim it resolved as of three days ago.


(Bifur) #10

I did another test on a fresh 15 install and 15.0.11.8 seems to have corrected the Marked Calls as Answered issue. If it is set to yes and a member of the ring group answers a call, the other phones do not show a missed call. If it is set to no then they show a missed call.

My original test was done on a server that was upgraded to 15 from 2.11 using the FreePBX Distro Conversion Tool. Ring groups did not work properly on this server using the ciscos but could be something else as I did have some other issues with it upgrading.

Thanks!


#11

That is good to know. Maybe I can start doing some upgrades to 15 now.