FreePBX 15.0.23 - Installed module updates now getting "'fwconsole reload' failed, config not applied"

Just trying to keep my FreePBX server up to date and install the module updates that were listed as available. After installing the updates I hit “apply config” as usual and now I’m getting these errors:

'fwconsole reload' failed, config not applied
Failed connect to 127.0.0.1:6001; Connection refused 

I tried to issue this command at the bash console:

fwconsole reload --verbose

But that fails and spits out this:

fwconsole reload --verbose
Reload Started

In Pest.php line 232:

  [Pest_Curl_Exec]
  Failed connect to 127.0.0.1:6001; Connection refused


Exception trace:
 () at /var/www/html/admin/libraries/pest/Pest.php:232
 Pest->doRequest() at /var/www/html/admin/libraries/pest/Pest.php:364
 Pest->post() at /var/www/html/admin/libraries/pest/PestJSON.php:46
 PestJSON->post() at /var/www/html/admin/modules/sangomartapi/Sangomartapi.class.php:410
 FreePBX\modules\Sangomartapi->nodeCall() at /var/www/html/admin/modules/sangomartapi/Sangomartapi.class.php:377
 FreePBX\modules\Sangomartapi->nodeReload() at /var/www/html/admin/modules/sangomartapi/Sangomartapi.class.php:363
 FreePBX\modules\Sangomartapi->postReloadFreepbx() at n/a:n/a
 call_user_func_array() at /var/www/html/admin/libraries/BMO/Hooks.class.php:212
 FreePBX\Hooks->processHooksByClassMethod() at /var/www/html/admin/libraries/Console/Reload.class.php:471
 FreePBX\Console\Command\Reload->reload() at /var/www/html/admin/libraries/Console/Reload.class.php:91
 FreePBX\Console\Command\Reload->execute() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Command/Command.php:255
 Symfony\Component\Console\Command\Command->run() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:960
 Symfony\Component\Console\Application->doRunCommand() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:255
 Symfony\Component\Console\Application->doRun() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:148
 Symfony\Component\Console\Application->run() at /var/lib/asterisk/bin/fwconsole:163

reload [--json] [--dry-run] [--skip-registry-checks] [--dont-reload-asterisk]

Per another similar post in Feb 2022 I tried to reinstall the sangomartapi module but that didn’t resolve the issue. I’m not sure what to do now.

Looks like I was able to start fwconsole with this command:

fwconsole start

I cleared the errors using the “-” symbol in the red circle that showed the error on the dashboard and now things seem happy, but I’m still left wondering that happened and why “fwconsole reload --verbose” didn’t work but “fwconsole start” does.

I have the same issue.

There is an open ticket for it, please vote for it : [FREEPBX-23560] Reload fails due to error: Failed connect to 127.0.0.1:6001; Connection refused - Sangoma Issue Tracker
So maybe this is fixed in the future.

If you aren’t using sangomartapi you can disable/remove it