Freepbx 14. Polycom ip450 won't provsion

I have this on a test server.

Polycom IP 450 won’t provision. The phones keep rebooting. Other phones work Ip430, VVX310, and Ip 6000. Any idea what to check?

In my messages log all I see them do is get the IP, I don’t see tftp log data. Forgot to say I’ve tried 2 different polycom IP450s. Neither have provisioned. I’ve as well done format file systems on them.

Need more info. Are you using OSS EPM or Endpoint Manager?

Literally yesterday I fixed a bunch of IP550s that had a similar sounding problem, but mine were failing on the application not found step. I submitted a ticket on the problem with commerce EPM if you want to go look at it.

I’m using the Endpoint Manager.

Is the phone rebooting on Application Not Found or are you having TFTP issues?

You need to set up a new value in the DHCP config so the phone knows where to D/L the firmware. Have you done that yet?

Other phones are downloading firmware. IP430’s, ip 6000, vvx310 all work. I have to bootloader check for looping.

Is something particular different than the common tftp options for dhcp?

There’s a particular option (42 ? 160 ? Maybe) that has to be passed to the phone through DHCP. When I set these up, I put the phone’s in their own group so I can control what options get sent and where.

Note that I troubleshot a problem like this recently where the existing phones had already been manually set up for TFTP and weren’t actually using the DHCP option, so when I added new phones to the network, they didn’t work like you are describing.

The option setting wasn’t right, but i made the assumption that it must be since the rest of the phones worked.

Option 66 & 160 are set to tftp://server" in string format.

The ip450 phones have been “format to file system” so I know they are blank.

If that option is set and formatted correctly, you should be seeing the phone trying to attach to the server. There are four files that it will download.

You’re using “tftp://192.168,.0.1/” and not trying to use a hostname, right? I’ve had problems with that in the past. Even if they don’t exist, it will try to download them. There are lots of peculiarities with tftp, so you might be running into one of those.

For example, you can watch the tftp port using 'tcpdump -I eth0 -p tftp" (or the numeric equivalent) and make sure the system is setting the probe at the port. If you are, but the accesses aren’t showing up in the /var/log/messages file, you might be having a firewall problem (be sure to turn tftp on in the integrated firewall).

Simply telling us “No, that isn’t it” without telling us what you are seeing, however, is a quick way to get people to stop helping you.

My ip range is different but I’m using tftp://10.20.220.10 as my host.

In sniffer using tcpdump -i eth1 port tftp I have 0 traffic from that device. In my /var/log/messages I do provide it an ip of 10.20.220.52 .

Other phones work like the ip430, ip6000, vvx310 & 311 so I pretty sure I have things setup right. Just not ip 450. I haven’t found any indicator the IP450 require some other dhcp option or some other option. I have lots of phones that I can test.

If anyone wants a capture file I can provide that as well but I see 0 tftp requests for the ip450 but lots for other phones. I have tried different cables, switch ports, and phones. I really don’t think this is a server side issue but rather a dhcp option that ip450 needs or needs in a particular format that the other models don’t.

tcpdump -i eth1 -vvnn host 10.20.220.52

should see the phone side traffic. Particularly after you reboot it and the phone is on the network that
eth1 services.

1 Like

I see the following

15:30:15.742971 IP (tos 0x0, ttl 64, id 39604, offset 0, flags [DF], proto ICMP (1), length 48)
10.20.220.10 > 10.20.220.51: ICMP echo request, id 56130, seq 0, length 28
15:30:16.743549 IP (tos 0x10, ttl 128, id 0, offset 0, flags [none], proto UDP (17), length 328)
10.20.220.10.67 > 10.20.220.51.68: [udp sum ok] BOOTP/DHCP, Reply, length 300, xid 0x35c81855, Flags [none] (0x0000)
Your-IP 10.20.220.51
Client-Ethernet-Address 00:04:f2:2e:45:78
Vendor-rfc1048 Extensions
Magic Cookie 0x63825363
DHCP-Message Option 53, length 1: Offer
Server-ID Option 54, length 4: 10.20.220.10
Lease-Time Option 51, length 4: 43200
Subnet-Mask Option 1, length 4: 255.255.254.0
Default-Gateway Option 3, length 4: 192.168.2.1
TFTP Option 66, length 12: "10.20.220.10"
NTP Option 42, length 4: 10.20.220.10
Time-Zone Option 2, length 4: -18000
Domain-Name-Server Option 6, length 4: 192.168.2.1
15:30:16.763007 IP (tos 0x10, ttl 128, id 0, offset 0, flags [none], proto UDP (17), length 328)
10.20.220.10.67 > 10.20.220.51.68: [udp sum ok] BOOTP/DHCP, Reply, length 300, xid 0x35c81855, Flags [none] (0x0000)
Your-IP 10.20.220.51
Client-Ethernet-Address 00:04:f2:2e:45:78
Vendor-rfc1048 Extensions
Magic Cookie 0x63825363
DHCP-Message Option 53, length 1: ACK
Server-ID Option 54, length 4: 10.20.220.10
Lease-Time Option 51, length 4: 43200
Subnet-Mask Option 1, length 4: 255.255.254.0
Default-Gateway Option 3, length 4: 192.168.2.1
TFTP Option 66, length 12: "10.20.220.10"
NTP Option 42, length 4: 10.20.220.10
Time-Zone Option 2, length 4: -18000
Domain-Name-Server Option 6, length 4: 192.168.2.1
15:30:16.765085 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 10.20.220.51 tell 10.20.220.51, length 46

FYI the comand was tcpdump -i eth1 -vvnn host 10.20.220.51 (for a polycom 450

As well I was expecting to see option 160 and 150 offered up as they are set in the dhcp connector.

H
FYI , you stated that the phone’s ip WAS .52

your DHCP server is at .67 but does NOT appear to offer options 150 or 160. , I would “check my work”

I added option 160 in

15:51:35.795564 IP (tos 0x10, ttl 128, id 0, offset 0, flags [none], proto UDP (17), length 349)
10.20.220.10.67 > 10.20.220.51.68: [udp sum ok] BOOTP/DHCP, Reply, length 321, xid 0x1df1e267, Flags [none] (0x0000)
Your-IP 10.20.220.51
Client-Ethernet-Address 00:04:f2:2e:45:78
Vendor-rfc1048 Extensions
Magic Cookie 0x63825363
DHCP-Message Option 53, length 1: Offer
Server-ID Option 54, length 4: 10.20.220.10
Lease-Time Option 51, length 4: 43200
Subnet-Mask Option 1, length 4: 255.255.254.0
Default-Gateway Option 3, length 4: 192.168.2.1
T160 Option 160, length 19: 116.102.116.112.58.47.47.49.48.46.50.48.46.50.50.48.46.49.48
TFTP Option 66, length 12: "10.20.220.10"
NTP Option 42, length 4: 10.20.220.10
Time-Zone Option 2, length 4: -18000
Domain-Name-Server Option 6, length 4: 192.168.2.1
15:51:35.809427 IP (tos 0x10, ttl 128, id 0, offset 0, flags [none], proto UDP (17), length 349)
10.20.220.10.67 > 10.20.220.51.68: [udp sum ok] BOOTP/DHCP, Reply, length 321, xid 0x1df1e267, Flags [none] (0x0000)
Your-IP 10.20.220.51
Client-Ethernet-Address 00:04:f2:2e:45:78
Vendor-rfc1048 Extensions
Magic Cookie 0x63825363
DHCP-Message Option 53, length 1: ACK
Server-ID Option 54, length 4: 10.20.220.10
Lease-Time Option 51, length 4: 43200
Subnet-Mask Option 1, length 4: 255.255.254.0
Default-Gateway Option 3, length 4: 192.168.2.1
T160 Option 160, length 19: 116.102.116.112.58.47.47.49.48.46.50.48.46.50.50.48.46.49.48
TFTP Option 66, length 12: "10.20.220.10"
NTP Option 42, length 4: 10.20.220.10
Time-Zone Option 2, length 4: -18000
Domain-Name-Server Option 6, length 4: 192.168.2.1

now I get the above and the phone reboots and does the same thing over

This is my dhcpd config

ddns-update-style interim;
ignore client-updates;

Log to the local0 facility by default

log-facility local0;
option polycom_server code 160 = string;
option tftp66 code 66 = string;
option tftp150 code 150 = ip-address;

subnet 192.168.122.0 netmask 255.255.255.0 {
}
subnet 10.20.220.0 netmask 255.255.254.0 {
option tftp66 “tftp://10.20.220.10”;
option tftp-server-name “10.20.220.10”;
option tftp150 10.20.220.10;
option ntp-servers 10.20.220.10;
option time-offset -18000;
option polycom_server “tftp://10.20.220.10”;
authoritative;
option routers 192.168.2.1;
#option domain-name “CFirst.local”;
option domain-name-servers 192.168.2.1;
pool {
option routers 192.168.2.1;
range 10.20.220.50 10.20.220.150;
}
}

Where do you see .67 for dhcp server?

There is no .67 host but maybe a phone.

The host is

[[email protected] ~]# ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.122.130 netmask 255.255.255.0 broadcast 192.168.122.255
inet6 fe80::5054:ff:fec1:8d1a prefixlen 64 scopeid 0x20
ether 52:54:00:c1:8d:1a txqueuelen 1000 (Ethernet)
RX packets 711775 bytes 720492538 (687.1 MiB)
RX errors 0 dropped 2 overruns 0 frame 0
TX packets 501798 bytes 293375222 (279.7 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 10.20.220.10 netmask 255.0.0.0 broadcast 10.255.255.255
inet6 fe80::5054:ff:fe6f:5905 prefixlen 64 scopeid 0x20
ether 52:54:00:6f:59:05 txqueuelen 1000 (Ethernet)
RX packets 40274 bytes 18003037 (17.1 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 50199 bytes 16977475 (16.1 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1 (Local Loopback)
RX packets 3603057 bytes 543669238 (518.4 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 3603057 bytes 543669238 (518.4 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Its a vm on a notebook pc in a lab. Adn the host doesn’t have a nic in that ip range. There is no server at the .67 ip.

I

I think the reference to .67 is the port dhcp is on in the sniffer dump. ie dhcp listens on port 67 and 68.

.My bad.

That doesn’t look exactly right.

Do we think we have a issue with conflict between the handouts?

option tftp66 “tftp://10.20.220.10”;
option tftp-server-name “10.20.220.10”;