Freepbx 14 No IPV4 Address After Post Installation Reboot


(United States) #21

The problem isn’t the assigning of an IP, it’s that after the install completes the onboot parameter for the interface is set to “no”.

Yeah I don’t seem to have that issue when assigning an IP during install, and as I mentioned I do this at least a couple times a week - however I have not tried to do an install using DHCP within the last several years or afaik ever.


#22

Maybe it’s only installs that use dhcp that encounter this problem but, given that the official Freepbx installation guide has the user get the dhcp assigned ip address from the machine console before using the gui to assign a static ip, I expect there’s an unusual hardware config scenario where the ethernet interface ends up not enabled. The low number of people that have posted here having encountered the same issue would seem to confirm.


(United States) #23

I’d suspect the centos installer is the issue, probably nothing to do with sangoma’s implementation (or your hardware :wink:). https://wiki.centos.org/FAQ/CentOS7#Why_does_my_Ethernet_not_work_unless_I_log_in_and_explicitly_enable_it.3F

This is actually a centos/rhel problem and doesn’t specifically relate to freepbx. Specifically it seems that if you “enable” your network card during install you wont have an issue

via the faq link above:

This can be worked around at install time where you have the possibility to enable your network card at the main installer screen, where the installer asks for your language/keyboard/storage devices/software installation.


#24

Agreed, good find with that link as well. The issue of nic being disabled at install can’t be consistent though or everyone following the Freepbx install guide would be running in to it.


(United States) #25

I agree, can you please post the URL of the install guide that you are looking at for us? Maybe we can get this fixed up in the guide or come up with a better solution.


#26

Sure,

https://wiki.freepbx.org/display/PPS/Installing+SNG7+Official+Distro

https://wiki.freepbx.org/display/FPG/Configuring+Your+PBX#ConfiguringYourPBX-SetaStaticIPAddressandConfigureDNS

The first sentence of the IP config section states “When FreePBX is first installed, it is configured to obtain an IP Address using DHCP”