Freepbx 14 No IPV4 Address After Post Installation Reboot


#5

I’m not an edge case, I fully intend applying a static ip address to the server, but if the server had no dhcp address assigned to begin with then I can’t access the admin gui to apply the static ip.

All I’m saying is that I installed Freepbx and the Ethernet interface was disabled and that I think that is unusual.


#6

Again, relying on DHCP to provide your network existence is just waiting for disaster. and again , what is your DHCP server?


#7

Again, there is nothing wrong with my network, after I set the ethernet interface to be enabled on boot and rebooted the Freepbx server, there was a dhcp address assigned, I logged into the admin gui and assigned a static ip, job done.

But I should not have had to edit the ifcfg-eth0 file in order to get the initial ip address.


#8

I don’t believe anyone else has that problem, maybe don’t use the “I just installed from SNG7-FPBX-64bit-1703-1.iso (downloaded from the Asia server which didn’t have the 1706 file”


#9

I had it, so I decided to note it here for future reference. The iso was downloaded from the mirror linked on the Freepbx website download page.


(R F) #10

Dave, thanks for this. I also had a similar problem. Installed a fresh VM using SNG7-FPBX-64bit-1707.iso. VM had 2 NICs, but only eth0 would show. Eth1 was listed with no ipv4 address from the console and would not appear in the drop-down under Admin/System Admin/Network Settings/Network Interface.
For those who are new at this, I’ll share what I did in case it also helps you:
(My interface was eth1, but substitute your one as appropriate)

ifconfig
to check your interfaces. If you have an interface that is present, but not connected, you’ll probably see it has no ip4 address.
cat /etc/sysconfig/network-scripts/ifcfg-eth1
You will see that ONBOOT=no
Change it to yes
nano /etc/sysconfig/network-scripts/ifcfg-eth1
Edit, then CtrlO to save and CTRLX to exit. Restart the network interfaces
/etc/init.d/network restart

Now you will see the interface is available to configure via the GUI and will show in the drop-down.


Self Assigned IP Issue
(Greg Theron) #11

My problem is if i set a static IP for eth0 the nic will not start on boot.
it is set to.
if i go back to DHCP it works fine.
i am only having this issue with 1707-1 distro on sangoman 60 servers.
if i reload it with 10.13.66-64bit i do not have this issue.
also if i do a fwconsole restart the nic will come up.
any ideas


(Pavle Milanovic) #12

Thanks man, this just solved my issue!
I downloaded the latest v14 FreePBX issue from the official freepbx website, transferred it to a USB, installed on a micro server and it just wouldn’t get the IP address automatically! When I checked, true enough, ONBOOT was set to no! Why do they ship them like this?? Like the original poster, I would usually install freepbx with a automatic IP address assigned by DHCP, then navigate to it from GUI and set the static there after configuring the system.
Don’t quite understand why they changed it to be like this on a fresh install…


(Mynor) #13

GOLD. 5/4/2018 I downloaded the freepbx distro from the website. I guess its still has an issue. But I notice that It randomly does it. because I put together another system with the same Iso and it worked fine. go figure.

r5eR FAug '17
Dave, thanks for this. I also had a similar problem. Installed a fresh VM using SNG7-FPBX-64bit-1707.iso. VM had 2 NICs, but only eth0 would show. Eth1 was listed with no ipv4 address from the console and would not appear in the drop-down under Admin/System Admin/Network Settings/Network Interface.
For those who are new at this, I’ll share what I did in case it also helps you:
(My interface was eth1, but substitute your one as appropriate)

ifconfig
to check your interfaces. If you have an interface that is present, but not connected, you’ll probably see it has no ip4 address.
cat /etc/sysconfig/network-scripts/ifcfg-eth1
You will see that ONBOOT=no
Change it to yes
nano /etc/sysconfig/network-scripts/ifcfg-eth1
Edit, then CtrlO to save and CTRLX to exit. Restart the network interfaces
/etc/init.d/network restart

Now you will see the interface is available to configure via the GUI and will show in the drop-down.


(Ulrik Pedersen) #14

This has also just saved me as well.
Thanks!


(Peter ) #15

And me! Thanks. I needed to use eth0 which would be self-evident to others after the initial login under root to see which Eth is in use.


(Kevin Brown) #16

Reinstalled Freepbx on my System 60
I had the same issues
Thanks for posting the fix


(Hd908) #17

Thank you for this! worked perfectly!


(Deutschland) #18

thanks for the hint !


(Scristopher7) #19

Why not just assign the static IP during the install? I’ve never had this issue but I always set a static during an install, and I typically do a couple of installs a week at the least.


#20

The problem isn’t the assigning of an IP, it’s that after the install completes the onboot parameter for the interface is set to “no”.


(United States) #21

The problem isn’t the assigning of an IP, it’s that after the install completes the onboot parameter for the interface is set to “no”.

Yeah I don’t seem to have that issue when assigning an IP during install, and as I mentioned I do this at least a couple times a week - however I have not tried to do an install using DHCP within the last several years or afaik ever.


#22

Maybe it’s only installs that use dhcp that encounter this problem but, given that the official Freepbx installation guide has the user get the dhcp assigned ip address from the machine console before using the gui to assign a static ip, I expect there’s an unusual hardware config scenario where the ethernet interface ends up not enabled. The low number of people that have posted here having encountered the same issue would seem to confirm.


(United States) #23

I’d suspect the centos installer is the issue, probably nothing to do with sangoma’s implementation (or your hardware :wink:). https://wiki.centos.org/FAQ/CentOS7#Why_does_my_Ethernet_not_work_unless_I_log_in_and_explicitly_enable_it.3F

This is actually a centos/rhel problem and doesn’t specifically relate to freepbx. Specifically it seems that if you “enable” your network card during install you wont have an issue

via the faq link above:

This can be worked around at install time where you have the possibility to enable your network card at the main installer screen, where the installer asks for your language/keyboard/storage devices/software installation.


#24

Agreed, good find with that link as well. The issue of nic being disabled at install can’t be consistent though or everyone following the Freepbx install guide would be running in to it.