FreePBX | Register | Issues | Wiki | Portal | Support

FreePBX 14 installed on Ubuntu. How to access commercial modules like Sysadmin


(Peter Arnold Nott) #1

I have followed this:https://wiki.freepbx.org/display/FOP/Installing+FreePBX+14+on+Ubuntu+18.04 to the letter and have got the system working.
BUT, what I really want is to set this up to be an emergency back up for my SNG7 system at work.
(long story, the working one is on a Chromebox CN60 and it was easy to load it on there from USB as the OS. I bought a Chromebox 3 to do the same, but for some reason which is thoroughly verified, you can’t load a replacement OS from a USB (Legacy boot is broken). When I went to do it using Mr Chromebox’s firmware, it couldn’t handle the kernel in the FreePBX. I am able to load Ubuntu, though. So here I am…)

Problem is, the steps outlined here do not give me access to the commercial modules like SysAdmin, and also does not give me the CLI, or the module where you can access the config files. Probably a bunch of others too.
Also, and probably for the same reason, I am unable to activate this installation.

Basically, I would like to know if there is any way of loading the full version of FreePBX, preferable the SNG7 version, onto Ubuntu 18.04.
Or if there is a way to fix the kernel panic when I load my SNG7 USB onto the modified chromebox.

My apologies if I am simply trying to do things that the system is not designed for.


#2

As far as I know, commercial modules are only supported on CentOS.


#3

If you can’t install the distro but need commercial modules, see
https://wiki.freepbx.org/display/FOP/Installing+FreePBX+13+on+CentOS+6#InstallingFreePBX13onCentOS6-InstallandSetupCommercialModules


(Peter Arnold Nott) #4

Yes, I’d come across that. But when I tried
root@peter-Teemo:/usr/src/freepbx# yum -y install php-5.3-zend-guard-loader sysadmin fail2ban incron ImageMagick
I get:
Error: Cannot retrieve repository metadata (repomd.xml) for repository: schmooze-commercial. Please verify its path and try again

Have I got my prompt line wrong? Or is it the command that is letting me down? Or is it just that I cant do this on ubuntu?


#5

I don’t know the details but there are many credible posts stating that commercial modules require CentOS.


#6

Pretty explicitly. . .

https://wiki.freepbx.org/display/FOP/Installing+FreePBX+14+on+Ubuntu+18.04


(Peter Arnold Nott) #7

This may be the wrong place for asking this follow up…and I am displaying my ignorance…is there an alternative equivalent to ubuntu I could load on my chromebox that gives me centos and access to these modules?


#8

But you will need a pretty beefy machine to support qemu running centos running a VoIP server virtualized

Docker is another possibility

But not easy for the very inexperienced.


(Tom Ray) #9

There is also the fact that FreePBX 14 runs on RHEL 7 not CentOS. Any docs referring to CentOS at this point are for v13.

V14 also uses PHP 5.6 so the ZendGuard for 5.3 will fail.


(Peter Arnold Nott) #10

So, looking at this another way: Is it possible to change settings in the Grub before installation that would get past this kernel panic? Like, is it possible to choose a more recent kernel such as 4.14 or so? So I could install from the SNG7 iso direct to my (adapted) chromebox as a stand alone and get away from Ubuntu? Or is the kernel set in the ISO and can’t be altered?
I am aware I have probably not used correct terminology but I’ve always been told there is no such thing as a stupid question…


#11

Would work for Ubuntu, you would likely be able to use any bootable Linux iso otherwise


(Peter Arnold Nott) #12

It would only be worth doing that if there is an alternative Linux iso that I could load something akin to SNG7. And the VM option looks too complex for what I need, which is literally for someone to just plug it in and turn it on.

I have a plan B for my backup now: I loaded the SNG7 onto a laptop with a broken screen and restored it with the backup from my production setup. That can sit in the corner until my working chromebox running FreePBX dies, as we all surely must.
I’ll use my fancy new chromebox with ubuntu loaded on it for something else I guess. pity.


#13

Well, the FreePBX distro (SNG7) could absolutely be considered an ‘alternative linux iso’ just wipe the box, and fire up seabios then choose to boot the USB iso stick you downloaded and burned and just answer the questions , not the live Ubuntu one as the link talks about.


(Peter Arnold Nott) #14

Yes, that was the plan, but the problem is this glitch in the basic setup on this particular model which led to me trying this workaround. This is according to Mr Chromebox on the Kodi wiki. Sorry that is not very technical. And using Mr Chromebox’s firmware, I run into that problem with the kernel panic when I load the SNG7 distro. But I am able to load Ubuntu.


#15

Just to be clear, when you wipe the Chromebox completely, you will have basic hardware, if it is an x86 based CPU then the Sangoma stuff will work. If it is arm, then yes, you are sol and will have to virtualized one way or another for commercial support.


(system) closed #16

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.