FreePBX 14 & EPM Stable? Issue with images and firmware

Hello All,

Putting together a new FreePBX 14 from distro, purchased & installed EPM and it appears that the firmware is not being updated, nor is the logo image being displayed.
Using Grandstream 2170’s.
I have a FPBX13 running perfectly with this same phone & EPM, so I know it’s not about the phone itself or the supporting of the phone from EPM.


hi, i have your setup, (freepbx, grandstream etc) and images never worked from the gui. firmware did depending on the delivery method. how are you sending firmware (http or https?). I use https and that is not supported in the gui, you have to edit the base file to make this work.

I use http for provisioning, works like a charm in freepbx13 for images and firmware.
I did verify my port settings for provisioning as well as my http configuration on the template for the phones.

I suggest you look at 2 things, first, tail -f /var/log/httpd/access_log | grep -i MacOfPhone and reboot a phone…do you see an http requests(make sure you have the correct mac)? if yes, then is apache returning 400 errors or 200 messages? If you see no attempts at all, then at then do a tshark -w /tmp/file.pcap ether host MacOfPhone this with give you a packet capture that might lead you to the answer

While nothing seemed logical with what was happening, I decided to uninstall EPM, re-install it and create new templates, which then worked.
This was a fresh install so, this makes a little less sense, but it’s working!