FreePBX 14 Distro SNG7 Install Fails on VM

I downloaded and validated checksum on SNG7-FPBX-64bit-1706-1.iso, attempted install on VirtualBox VM configured for Redhat 64 with 4 cores and 8 Gigs RAM, 80G SATA HD. After 5 attempts with different install options (fully automatic, custom partitioning, select software, etc.) it hangs at “Installing FreePBX (571/649)”.

Does anyone know what package 571 of 649 might be?

There is a 1707-1 I don’t know what is fixed in that…
62ea556d555fbb9fe8e127884c128462 SNG7-FPBX-64bit-1706-1.iso

Oops! Sorry, the issue occurs with 1707-1. I cut & pasted the wrong file name from my download folder. I downloaded 1706-1 on 7/20 and got around to creating a VM to try it out last weekend. 1706-1 also hung at 571/649 with various install options. I thought it might be a media issue so I downloaded the ISO again and went through the MD5sum procedure with 1707-1. I didn’t notice it was a new ISO version, but I get the same result with 1706-1 and 1707-1.

Any ideas?

I just installed this(1707) on a VirtualBox W10 host, but I used Linux/Other Linux 64bit and 2 core, 3.5gb RAM, and 25gb HDD. I had the same “hang” at 571(freepbx). I monitored it for 30 minutes with no change, so I let it go and when I got home from work about 18 hours later it had completed successfully.

1 Like

Guys that is the FreePBX RPM and currently it can take a long time to install because of the nodejs stuff. On slow internet it can be a hour.

When VM was crerated for Redhat 64, I let it run for hours and it stayed hung. But when I installed with “Other Linux” as infinit3shift suggested, it successfully installed in under 2 hours. (I have 100Mb connection) So I guess Sangoma 7 is not in the Redhat family as far as VirtualBox is concerned.

But its up now! Looks good so far.

Sangoma 7 is a centos variant which is in the redhat family. So yes it is. As Tony said the freepbx rpm can take a long time.

Yes, and Schmooze always worked with RedHat 64. I have no clue what is different in VM architecture in VirtualBox when you select “RedHat” or “other” in VM creation, but I believe that is why it hangs. Just out of curiosity, I’m going to try to reproduce with nothing different except Linux selection. I had let the install run hung at 571 for almost 8 hours. Again out of curiosity, what is 571?

571 is just the RPM number. Its saying its working on RPM number 571 of 649. It will also say its the FreePBX RPM.

I have installed FreePBX 14 Distro on Vultr using the ISO pulled over directly from Sangoma with no issues.

I have also just today completed a successful load to VMWare. Tested. Works. Enjoy.
Step 22 is especially important.

FreePBX 14 Distro (1707-1)
Installation on VMWare Workstation Pro 12 (Windows 10 Pro Version 1703)

Updated from YouTube the excellent video by Chris of Crosstalk Solutions ( without which I would still be trying to figure this out. Thanks!

Time Budget on fast equipment with fast connections: ~1 hour or much longer if PC or Internet are slow

  1. Click on New Virtual Machine in VMWare Workstation Pro 12

  2. Select Typical on the Welcome to the New Virtual Machine Wizard then click Next

  3. Click “I will install the operating system later” and click Next

  4. Select “Linux”

  5. Under version select "Other Linux 3.x kernel 64-bit then click Next

  6. Name the virtual machine (i.e. FreePBX 14 64-bit Distro)

  7. Change location if desired and click Next

  8. Recommend 20gb disk capacity, allow split into multiple files

  9. Click Customize Hardware

  10. Set memory slider to 1GB (1024MB)

  11. Click New CD/DVD

  12. Click Use ISO Image File, browse for the ISO (i.e. SNG7-FPBX-64bit-1707-1.iso)

  13. Select ISO file you previously downloaded and click Close

  14. Click Finish

  15. Click Power on this virtual machine

  16. Click OK on Removable Devices pop-up, the Sangoma setup screen should be visible

  17. As of August 2017, Asterisk 14 is still “in work” so press Enter to accept recommended Asterisk 13

  18. Press Enter at Installation - Output to VGA

  19. Press Enter at FreePBX Standard

  20. Sangoma GUI installer will begin, and will pause for a long time at Installing freepx step 571/649 as noted by numerous users online - this is normal

  21. Do not proceed to next step until Root password is set. This can be done while the install is taking place…a good time is during step 571! Click on the “root password not set notification,” set your password, then click on Done to return to the install screen.

  22. Perhaps get a cup of coffee now. Even if you have a very fast network connection (75mb in my case) you may have time for a brief but meaningless affair - or two - during step 571. Read a book…write a short story…bake a cake…any - or maybe all - of these are possible during step 571. Your system has NOT hung. Do not escape out or get impatient. On a very fast machine, with very fast hard drives and a super fast connection, step 571 took about 30 minutes for me. Enjoy the Sangoma commercials scrolling along the bottom indicating that your machine is indeed still running.

  23. Once step 571 completes, the remaining steps including installation of Asterisk are completed in short order.

  24. Post-installation setup tasks take about 5 minutes with no meaningful feedback from the install script. Be patient. Perhaps repeat portions of step 22.

  25. Some additional housekeeping steps take place after post-installation setup. initramfs generation takes a few minutes. More patience is in order.

  26. BEFORE rebooting the now-installed FreePBX system, click on the “I finished installing” button at the bottom of the screen in VMWare Workstation.

  27. Click Reboot on the Sangoma screen. Wait patiently for the freepbx login to appear. Enter “root” and then the password you assigned at step 21.

  28. If all goes well, you will be rewarded with the Linux FreePBX banner screen in terminal mode. Note the IP address assigned (likely 192.168.xx.xx), switch over to a browser and enter this IP address. Note, there is an option to assign an IP address in VMWare setup which you would want to do if you are going to use this install in production rather than allowing DHCP to assign a new IP at each reboot.

  29. If you do not receive the Sangoma GUI (I did not in Microsoft Edge) then ping the IP from a command prompt to see if you get a response (I did). Switch to a different browser and reinput the IP. You should now be rewarded with a FreePBX admin login screen and be able to proceed with a normal setup to arrive at the Dashboard.

Success! FYI the FreePBX 14 distro ISO also loads flawlessly on Vultr cloud with no gymnastics required.


Excellent documentation! I especially love step 22. Impatience has always been one of my virtues. I gave my VirtualBox VM 8 cores and 32 gigs and installed in less than an hour. I think Sangoma should put in a message, “Please wait … and wait …and wait …”

I wish we could put a message like that but the anacodna installer has no support for such a thing or we would.


Hello. I was fortunate enough to be running my VM on a laptop, and the flashy lights told me that HD and network access was still occurring. Also ran a sniff on the switch, and yep, packets are moving through.

Perhaps put up a screenshot message in the Sangoma adspace about the delay. Information is important.

I happened to stumble across this thread looking for details on the installation screen at the very beginning. Insight onto what all the options mean.

Unfortunately we can’t do this. Thank you for your input though.

Actually what we could do is create a ad that rotates at the bottom with the other ads. It would rotate through the whole cycle of install that just states ATTN: FreePBX RPM can take 30 or more minutes to install type of thing so people are not wondering.


Thanks Tony for a far more technically obvious and customer-centric answer than “Thank you for your input. We can advertise our phones and switches and support but we can’t use the same method to advise you to be patient during the install.” Your solution would probably reduce support traffic as 14 rolls out.

I never said all of those words nor did I even imply that. Please open a ticket on this otherwise it will be forgotten.

Thanks again.

Why does the distro not bring up the interface?

I do not run DHCP in the network that is used for my PBX’s.

So I do the following after step 19 I setup the timezone, I setup networking with the static IP, netmask, gateway, and dns servers. Then I proceed. I have setup a 4 GB partition for /var/log but I have also not done that and been stuck with the same 571 hang.

So i tried to ping the static IP i setup and what do i see request timed out???

I have left this VM run for 2 hours which should be done in 10 minutes.

Am i missing something? It looks like my interface is not online hence the reason for sitting at 571 where it is trying to go out and install where there is no network connectivity.

And yes i verified that after clicking Save it said connected.

Thoughts? Has anyone else seen this?

I’m at fault for my problems.

I was choosing the wrong network when deploying the VM.

All is good with installation and like stated above step 22 is the longest step.

I been waiting a l–o--n–g time, at step 584/662 using latest ISO. Presume its the same issue, with a new package number.
Very glad I found this thread, otherwise I would have given up long ago and rebooted.
If node.js causing the delay, might there be a different way to distribute the node.js package rather than live download from the interwebs ?
Any way to include that package in the ISO itself ?
I’ve installed many distros from ISO packages, and nothing ever takes this long.
I better go for a swim or catch some waves.
Back later.

[Edit] Just bumped up to 588/662, so somethings are 'appening.