FreePBX 14.0.8.4, asterisk crashing, system is updated

Hi everyone,
I’m running FreePBX 14.0.8.4, 16 GB, 4xCPU on Vmware ESXi 5.5 for 60 phones and maximun of 15 simultaneous calls. FreePBX and modules are updated.

Asterisk crash 3~4 times every day. All calls busied out, GUI display “cannot connect to asterisk” and CLI hung. Phone never loose registration, not packets dropped. Server and phones are on same network.

Rebooting the server or sometimes ‘fwconsle restart’ do the trick.
Already check all the performance graph on Vmware and Linux (top, iotop, atop).
Logger stop working too (var/asterisk/full).
Using Asterisk -rvvvvvv, nothing is received.

When using fwconsole restart sometimes is received “Core FastAGI Server is not running”.

Could someone give me some clues what’s going on?
Thanks

Regards

Output#1:

[[email protected] ~]# fwconsole restart
Core FastAGI Server is not running
UCP Node Server is not running
Chat Server is not running

In php-asmanager.php line 489:

fclose(): 111 is not a valid stream resource

restart [-i|–immediate] [–] []…

Output #2

[[email protected] ~]# fwconsole restart
Running FreePBX shutdown…

Core FastAGI Server is not running
Stopping UCP Node Server
[>---------------------------] < 1 sec
Stopped UCP Node Server
Stopping Chat Server
Stopped Chat Server
Shutting down Asterisk Gracefully. Will forcefully kill after 30 seconds.
Press C to Cancel
Press N to shut down NOW
[============================] 30 secs
Killing asterisk forcefully.

Running FreePBX startup…
Running Asterisk pre from Firewall module
Running Asterisk pre from Sysadmin module
Running Sysadmin Hooks
Restarting fail2ban
fail2ban Restarted
Updating License Information for 52998861
Checking Vpn server
Starting Asterisk…
[============================] 2 secs
Asterisk Started
Running Asterisk post from Core module
Running Asterisk post from Endpoint module
Running Asterisk post from Ucp module
Starting UCP Node Server…
[>---------------------------] < 1 sec
Started UCP Node Server. PID is 41849
Running Asterisk post from Xmpp module
Starting Chat Server…
[>---------------------------] 1 sec
Started Chat Server. PID is 41967

Asterisk version? Are you aware of this issue:

Asterisk 13.26.0. Does that means I hitting a bug? OMG
Thanks for your response.

I used the command: yum downgrade asterisk13*. After done:
pbx*CLI> core show version
Asterisk 13.26.0

Why is not showing version 13.22?

need to restart post downgrade:

fwconsole restart

I tried fwconsole restart and rebooted server, but same result.
Do you have any suggestion?

asterisk-version-switch

choose 13 again

Because you were on 13.26.0-2 and you downgraded to 13.26.0-1

1 Like

I tried several time with “yum downgrade asterisk13*”. Now running version 13.23.

Is there any bug with that version?
Thanks

There isn’t a bug with 13.26. Did you even read what Lorne first replied to you?

Yes, I read asterisk 3.26 were removed from SNG7 for complaints about Asterisk instability.

I was running Asterisk 3.26 from SNG7. I downgrade to 3.23
Could you please clarify?

Thanks

Please re-read the message in it’s entirety. Everything is clarified there.

I read issue was solved on version 13.26-3. I preferred to downgrade instead of upgrade. Downgrade didn’t work.

Do you suggest to upgrade to 13.26.-3?
I run: fwconsole ma upgradeall. Nothing happen.

Do you have any suggestion?

What is the result of:

yum list asterisk13

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.