FreePBX 13 won't start asterisk after reload

Using the instructions on:
I installed this on CentOS 6.9 in Azure.
I tried several times and each time after the last step i’m able to reach the GUI and Asterisk without any issue but if I issue a reload, asterisk doesn’t start and I have a big red box, “Cannot connect to asterisk”

/etc/var/messages shows this error repeating:

Jun 27 16:50:37 azsc-voip-2 kernel: asterisk[4376]: segfault at 48 ip 00007fbbdda27531 sp 00007ffc5ddeef40 error 4 in[7fbbdda23000+d000]
Jun 27 16:50:37 azsc-voip-2 abrt[4446]: Not saving repeating crash in '/usr/sbin/asterisk'
Jun 27 16:50:43 azsc-voip-2 abrt[4446]: Saved core dump of pid 4376 to core.4376 at /tmp (102215680 bytes)
Jun 27 16:50:49 azsc-voip-2 kernel: asterisk[4454]: segfault at 48 ip 00007faa46307531 sp 00007ffea64e2ff0 error 4 in[7faa46303000+d000]
Jun 27 16:51:00 azsc-voip-2 abrt[4524]: Saved core dump of pid 4454 (/usr/sbin/asterisk) to /var/spool/abrt/ccpp-2017-06-27-16:50:49-4454 (102211584 bytes)
Jun 27 16:51:00 azsc-voip-2 abrtd: Directory 'ccpp-2017-06-27-16:50:49-4454' creation detected
Jun 27 16:51:00 azsc-voip-2 abrtd: Executable '/usr/sbin/asterisk' doesn't belong to any package and ProcessUnpackaged is set to 'no'
Jun 27 16:51:00 azsc-voip-2 abrtd: 'post-create' on '/var/spool/abrt/ccpp-2017-06-27-16:50:49-4454' exited with 1
Jun 27 16:51:00 azsc-voip-2 abrtd: Deleting problem directory '/var/spool/abrt/ccpp-2017-06-27-16:50:49-4454'

I tried stopping and restarting the service manually but it never returned “OK” after starting the service back up. Not sure what I might be doing wrong.

I have an identical VM built that appears to be running FreePBX 13 well.

touch /etc/asterisk/ari.conf

1 Like

This is a bug in asterisk. You need to create the ari.conf (empty), otherwise asterisk will continuously crash. Sorry 8-(

Asterisk 13.17.0-rc1/14.6.0-rc1 (ultimately Asterisk 13.17.0/14.6.0) will resolve this without the touch thing

1 Like