FreePBX | Register | Issues | Wiki | Portal | Support

Freepbx 13 to 14 upgrade webserver / Apache not starting

freepbx
Tags: #<Tag:0x00007fafc5555cb8>

(ADTopkek) #1

This isn’t a question I am just documenting what I did to fix a problem while upgrading to freePBX 14 to help others and myself in the future. I didn’t find this info while searching so maybe now someone else can find it.

I was running the freepbx 13 distro ISO. I ran the Freepbx 13 -> 14 upgrade script and ran into an apache problem along the way. It would not start.

service httpd restart
Redirecting to /bin/systemctl restart httpd.service
Job for httpd.service failed because the control process exited with error code. See “systemctl status httpd.service” and “journalctl -xe” for details.

I checked the journalctl

– Unit httpd.service has begun starting up.
httpd[25309]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
httpd[25309]: (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:81
httpd[25309]: no listening sockets available, shutting down
httpd[25309]: AH00015: Unable to open logs
systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
kill[25311]: kill: cannot find process ""
systemd[1]: httpd.service: control process exited, code=exited status=1
systemd[1]: Failed to start The Apache HTTP Server.
– Subject: Unit httpd.service has failed
– Defined-By: systemd
– Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel

– Unit httpd.service has failed.

– The result is failed.
systemd[1]: Unit httpd.service entered failed state.
systemd[1]: httpd.service failed.

I found out that in /etc/httpd/conf/httpd.conf it was set to listen on port 80 as is expected:

# Change this to Listen on specific IP addresses as shown below to
# prevent Apache from glomming onto all bound IP addresses.
#
Listen 80

So the system was listening on port 80 as it should. The problem is that it was told to listen a 2nd time at /etc/httpd/conf.d/schmoozecom.conf

# Automatically Generated File
# Starting acp
# acp
Listen 80
< VirtualHost *:80>

All I did was comment out the listen in /etc/httpd/conf.d/schmoozecom.conf and it worked after a “service httpd restart”

# Automatically Generated File
# Starting acp
# acp
#Listen 80
< VirtualHost *:80>

Hope this helps someone else!


#2

This worked for me!!

Thank you!