FreePBX 13 getting HEP/CaptAgent up, and running

So, I see there is no hep.conf file so I created one, gave it permissions with fwconsole chown (yes confirmed ownership is asterisk:asterisk), and placed some the minimal settings needed.

I set the needed modules to load in modules.conf, then reload.

Then looking in Asterisk:

localhost*CLI> module show like hep
Module Description Use Count Status Support Level HEPv3 API 0 Not Running extended PJSIP HEPv3 Logger 0 Not Running extended RTCP HEPv3 Logger 0 Not Running extended

Hmmm…not running

in the “full” log I see:

[2018-01-22 14:50:07] ERROR[16774] config_options.c: Unable to load config file ‘hep.conf’
[2018-01-22 14:50:10] WARNING[16774] res_hep_rtcp.c: res_hep is not loaded or running; declining module load
[2018-01-22 14:50:10] WARNING[16774] res_hep_pjsip.c: res_hep is not loaded or running; declining module load

So any ideas on why hep.conf cannot be loaded?

what is in your hep.conf file?

I copied directly from a base Asterisk install.

; res_hep Module configuration for Asterisk

; Note that this configuration file is consumed by res_hep, which is responsible
; for the HEPv3 protocol manipulation and managing the connection to the Homer
; capture server. Additional modules provide specific messages to be sent to
; the Homer server:
; - res_hep_pjsip: Send SIP messages transmitted/received by the PJSIP stack
; - res_hep_rtcp: Send RTCP information (all channels)

; All settings are currently set in the general section.
enabled = yes ; Enable/disable forwarding of packets to a
; HEP server. Default is “yes”.
capture_address = ; The address of the HEP capture server.
;capture_password = foo ; If specified, the authorization passsword
; for the HEP server. If not specified, no
; authorization password will be sent.
capture_id = 2235 ; A unique integer identifier for this
; server. This ID will be embedded sent
; with each packet from this server.
uuid_type = call-id ; Specify the preferred source for the Homer
; correlation UUID. Valid options are:
; - ‘call-id’ for the PJSIP or chan_sip SIP
; Call-ID
; - ‘channel’ for the Asterisk channel name
; Note: If ‘call-id’ is specified but the
; channel is not PJSIP or chan_sip then the
; Asterisk channel name will be used instead.

1 Like

did you load the relevant modules and do they exist ?

ls /usr/lib*/asterisk/modules/res_hep*


module load
module load
module load

Thanks for responding dicko, but didn’t you see where I pasted where I show the output from the “module show like hep” command?

Indeed I did, but did you load them yet? When the load properly they will show as running, if they don’t load then it should show why

As I also indicated, I did put load = in modules.conf and verified they are in the Asterisk modules directory

ls /usr/lib*/asterisk/modules/res_hep*


load =
load =
load =

Watch the comand line as you, one by one,

module unload res*
module load res*

WARNING[32419]: loader.c:654 ast_unload_resource: Unload failed, ‘res*’ could not be found

WARNING[32419]: loader.c:1054 load_resource: Module ‘res*’ could not be loaded.

replace the * with a “real thing” there are three of these “real things” use tab completion to see what asterisk thinks you have

> (module load res_hep<TAB>)

1 Like

Okay, all unloads failed, but the loads were successful.

module show like hep
Module Description Use Count Status Support Level HEPv3 API 0 Running extended PJSIP HEPv3 Logger 0 Running extended RTCP HEPv3 Logger 0 Running extended
3 modules loaded

That may help for now, but when happens on a reload, or restart?

It should work if they are loaded first in modules.conf and there are no conflicting instructions in that file.

Just did an fwconsole restart on the pbx, and the modules are aokay.

Still find it dd why it did that.

Thanks a bunch Dicko!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.